On 11/20/2010 12:14 AM, Rugxulo wrote:
> ...
> What year and model and cpu? Just curious. And what exactly doesn't
> work, it won't turn on??
DELL Latitude XP 475D
Plugged it in, hit the switch and nothing. No lights, no sound, nothing.
It has been going for years and I only kept it for the last year or two 
to compile C programs under FreeDOS.
> ...
> Hmmm, I know I read your recent message, but you were kinda vague.
> What exactly doesn't work? What error message does it give? What
> version of Borland C? And most importantly, what kernel are you using?
> (try "ver /r") It's most likely an issue on your end since I haven't
> heard of any Borland tools having issues except maybe Turbo C 3.0, but
> I think they fixed that in later kernels. So you should definitely try
> kernel 2038 (instead of 2036 from FD 1.0) or even "unstable" 2039.
ver -r (or -R, despite the help info) gives

FreeCom version 0.84 pre2 XMS_Swap [Aug 28 2006 00:29:00]

I'm pretty sure that it's the version because I had been compiling 
various C programs in the Borland C IDE for years and as soon as I 
upgraded, it stopped compiling. I just tried it again with a program 
that I know would compile and got:

Undefined symbol _EGA_VGA_driver in module STRZ2.C

When it first happened, the "undefined symbol" would be whatever library 
or object file was to be linked in first. I checked the paths, checked 
that the libraries and object files were there, tried to manually 
compile and link, tried stupid things like copying the object files into 
the code directory, etc. It was then that I copied a minimal Borland C 
setup to the old DELL that still had the previous FreeDOS version and 
... it worked! As I had to get the program compiled and was able to, I 
didn't complain and thought that I would eventually be able to fix the 

> EDIT: Does this link help? But I'd rather you didn't use this and
> instead told us more specifically what's wrong. Most FreeDOS users
> don't use Borland tools except (freeware) TC++ 1.0.1 or TC 2.01 or TP
> 5.5.
> http://ftp.usf.edu/pub/freedos/files/distributions/official.old/0.9sr2.BETA/
Thanks, I'm downloading it now.

> P.S. Worst case scenario, you could always use OpenWatcom, right? It's
> far better than Borland anyways (and official compiler for FD, natch).
My choices appear to be three:

Downgrade to pre 1.0 FreeDOS and hope that I can once again do the 
development work on this PC. This is the best option, as I don't do a 
lot of this anymore, and I wouldn't have to change anything.

Move from Borland C to Watcom. I agree with your opinion about Watcom, 
but I have an awful lot of code that depends upon Borland graphics 
drivers (and probably a few other Borland things), and I don't want to 
rewrite it. So it would be a worst case scenario. I would rather port 
the whole thing to Linux and run it under Real Time Linux.

Fix whatever is going wrong with the present setup. The error messages, 
as explained above, are those awful sort that say "X isn't there" and 
when you look, X is there. My guess is that there was some subtle change 
in a DOS or BIOS filesystem call between 0.9 and 1.0 and it broke the 
ability of the Borland system to find objects to be linked.

Anyway, I'll try the first option now and let you know how I go. Thanks 
for your interest, and of course the link to the old distribution.


Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today
Freedos-user mailing list

Reply via email to