First, it was not necessary to re-install FreeDOS.

Lynx, Ntool, and all other WATTCP programs are applications, not part of the 
operating system.
The only OS related thing to consider is whether the packet driver is loaded. 

It sounds like now that your virtual machine settings may have changed such 
that DHCP is not

But back to your original problem - how to know if you are accessing the right 

You can add a line to WATTCP.CFG using the PRINT directive.  So create a 
which contains only the following line:

PRINT = "James WATTCP.CFG file has been accessed"

Or whatever text you want.  When you run either NTOOL or LYNX if you see this 
line printed out during
initialization then you know that your config file and not that of some evil 
genius, has been accessed.

WATTCP will access one and only one config file.     First it looks at the 
environment variable WATTCP.CFG which represents a directory (not a file name!) 
if this environment variable does not exist it uses the current directory. It 
looks first for the file name WATTCP.CFG and if not found for the file name 

I recommend playing around with different config files using the PRINT 
directive to completely understand which file the applications will access.  
You could have one file in directory c:\tmp with PRINT = "config file in TMP" 
and another file in C:\BIN with PRINT = "config file in BIN" and try to access 
these files by being in the current directory and using the WATTCP.CFG 
environment variable.

In any case your applications will access one and only one WATTCP.CFG file 
(unless that config file has the INCLUDE directive).

So that will eliminate a mystery config file setting some strange IP address 
and get you to the point where you completely understand which config file is 
being used.

Regarding DHCP not working anymore that sounds like an incorrect packet driver 
for your VM or a setting on the VM or a virtual bridge misconfiguration.  





-----Original Message-----
From: James Collins <>
To: freedos-user <>
Sent: Sat, Mar 19, 2011 11:15 am
Subject: Re: [Freedos-user] ntool help


I reinstalled freedos to get a fresh start.

I just now have been fooling around with ntool and mTCP. 

just now I got dhcp under mTCP to work. but now it isn't working. I can't get 

ntool to work either? 

when I run dhcp through mTCP I get an error: failure to get dhcp address. check 

your cabling and packet driver settings.

I have tcp.cfg, edited and I have the packet driver that I need. and the packet 

driver is loaded via autoexec.bat.

and I just got dhcp to work. when I run ntool I get bootp/dhcp failed.

like I said I reinstalled freedos, one reason I did reinstall was to try to 

figure anything about wattcp.cfg.

as far as I know I have wattcp.cfg in


I edited wattcp.cfg to just have the line my_ip=dhcp

when I run ntool and it fails, I then look at wattcp.cfg and it is empty? like 

the my_ip=dhcp is gone. mtcp's dhcp doesn't do this. 

I just renamed wattcp.cfg to wattold.cfg and ran ntool again it ran without any 

error and wrote nothing to the screen.

this makes me think that these programs are like you said getting a fixed ip 

somewhere. but I am not sure.

like I said I reinstalled freedos. 

any help would be appreciated

Sent from my iPhone

On Mar 17, 2011, at 6:20 PM, "Willi Wasser" <> wrote:

>> i just tried to run ntool and i got back an ip address of:

>> MY_IP=


> NTOOL is a WATTCP application itself, one that is linked to a relatively 

recent version of the WATTCP library that does support dhcp properly. That 

means, it will try to get its ip parameters from dhcp if the WATTCP.CFG file it 

finds at program start tells it to do so by specifying "MY_IP=DHCP" or if it 

doesn't find a WATTCP.CFG file at all. In this case it will write something 

"Configuring through BOOTP/DHCP" to the screen.


> If on the other hand it finds a WATTCP.CFG file that defines a static ip 

address, then it will simply accept this setting, assuming that you know what 

you are doing. Nevertheless NTOOL -g " " will output the actual ip parameters 

that are in effect in this moment.


> So if NTOOL just tells you "MY_IP=" without any message about using 

dhcp, then you probably have a WATTCP.CFG file somwhere which defined that 

address. Probably you just copied that file from somewhere and failed to adjust 

it to your personal needs. Try to find that file and make it "invisible" to the 

program, by re-naming it or by deleting it completely.


> If that helps, you could even try whether you need NTOOL (or any other 

external dhcp client) at all. Perhaps lynx just has the very same problem? If 

the lynx version you use, is also linked to a more recent version of WATTCP, 

then it could do this all by itself. It not, you could still use NTOOL.


> ___________________________________________________________

> Empfehlen Sie WEB.DE DSL Ihren Freunden und Bekannten und wir   

> belohnen Sie mit bis zu 100,- Euro!
> ------------------------------------------------------------------------------
> Colocation vs. Managed Hosting
> A question and answer guide to determining the best fit
> for your organization - today and in the future.
> _______________________________________________
> Freedos-user mailing list

Colocation vs. Managed Hosting
A question and answer guide to determining the best fit
for your organization - today and in the future.
Freedos-user mailing list

Colocation vs. Managed Hosting
A question and answer guide to determining the best fit
for your organization - today and in the future.
Freedos-user mailing list

Reply via email to