Martin Kosek wrote:
On 04/18/2014 01:40 PM, Petr Viktorin wrote:
On 04/18/2014 01:29 PM, Martin Kosek wrote:
On 04/18/2014 10:52 AM, Petr Viktorin wrote:
On 04/18/2014 10:33 AM, Martin Kosek wrote:
FYI - I saw numerous questions about "ipa" tool backward compatibility (the
most recent is https://bugzilla.redhat.com/show_bug.cgi?id=1089015), so I
created a section about it:

http://www.freeipa.org/page/Client#Compatibility

and added it to FAQ.


Looking for the version in an internal module doesn't strike me as the best
method. Especially if you have to add a warning to not change the file. (And
changing it is just "discouraged"? Really?)

I specifically added the warning about changing it because this is what the
user in the Bugzilla did and I really want to discourage people doing that. If
you have better wording in mind, please feel free to improve :-)

I'd rather not mention it at all; saying "here is a stupid thing you really
shouldn't do" will just make people do it.

Umm, ok, makes sense :) I removed the warning.


As another data pint, ipa ping will show the server version:

# rpm -q freeipa-client
freeipa-client-3.3.90GIT6044229-0.fc20.x86_64

# ipa ping
------------------------------------------
IPA server version 3.0.0. API version 2.49
------------------------------------------

# ipa user-show admin
ipa: ERROR: 2.81 client incompatible with 2.49 server at ...

rob

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to