Operator should be :=. Check first that you have sql checking enabled in
radiusd.conf:

#  Session database, used for checking Simultaneous-Use. Either the
radutmp
#  or rlm_sql module can handle this.
#  The rlm_sql module is *much* faster
session {
#       radutmp

        #
        #  See "Simultaneous Use Checking Querie" in sql.conf
        sql
}

Then set nastype in clients.conf to other. If it works after that,
problem is most likely OID that checkrad uses. You will need to find the
correct one for your NAS and alter it in checkrad. Then you can change
other to cisco or whatever.

Ivan Kalik
Kalik Informatika ISP


Dana 12/4/2007, "PD" <[EMAIL PROTECTED]> piše:

>Dear all,
>
>We has the problem regarding the above subject...
>mysql> select * from radgroupcheck;
>+----+-----------+------------------+----+-------+
>| id | GroupName | Attribute        | op | Value |
>+----+-----------+------------------+----+-------+
>|  1 | POSTPAID  | Simultaneous-Use | == | 1     |
>|  2 | PREPAID   | Simultaneous-Use | == | 1     |
>+----+-----------+------------------+----+-------+
>2 rows in set (0.01 sec)
>mysql> select * from usergroup;
>+----------+-----------+----------+
>| UserName | GroupName | priority |
>+----------+-----------+----------+
>| thomas   | POSPAID   |        1 |
>| christie | POSPAID   |        1 |
>+----------+-----------+----------+
>2 rows in set (0.01 sec)
>
>and at sql.conf..
>...
># Uncomment simul_count_query to enable simultaneous use checking
># simul_counT_query = "SELECT COUNT(*) FROM ${acct_table1} WHERE
>UserName='%{SQL-User-Name}' AND AcctStopTime = 0"
>simul_count_query = "SELECT COUNT(*) FROM ${acct_table1} WHERE
>UserName='%{SQL-User-Name}' AND AcctStopTime = 0"
>simul_verify_query = "SELECT RadAcctId, AcctSessionId, UserName,
>NASIPAddress, NASPortId, FramedIPAddress, CallingSta
>tionId, FramedProtocol FROM ${acct_table1} WHERE
>UserName='%{SQL-User-Name}' AND AcctStopTime = 0"
>...
>
>But.. the same user id still able to login at the same time on different
>terminal / pc
>
>I already try to change the op on radcheck from '==' become ':=' or
>'=' but the same problem still persist
>
>What could be wrong ?
>
>TIA
>
>PD
>
>-
>List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html
>
>

- 
List info/subscribe/unsubscribe? See http://www.freeradius.org/list/users.html

Reply via email to