Bill Page wrote:
> 
> Waldek,
> 
> On Thu, Oct 15, 2009 at 4:40 PM, Waldek Hebisch
> <[email protected]> wrote:
> >
> > Bill Page wrote:
> >> Waldek,
> >>
> >> I have a few more patches that I would like to get into FriCAS before
> >> the next release but really none of them are "critical". ?Here's one
> >> for XPOLY. It adds a couple of missing functions. ?I first mentioned
> >> this patch here:
> >>
> >> http://lists.gnu.org/archive/html/axiom-math/2006-03/msg00003.html
> >>
> > ...
> > It seemse that we could just use divide as name of operation.
> > Then we will re-use implementation from FreeMonoid.
> >
> 
> Ah, yes indeed, good idea.  But should we change 'div' to 'divide' in
> OrderedFreeMonoid or vice versa in in FreeMonoid. Given that 'divide'
> is used in three other places to return quotient and remainder, it
> seems to me that using 'div' might be more consistent Or maybe sense
> we already have 'rquo' and 'lquo' in both domains, maybe simply
> changing both 'div' and 'divide' to  'quo' would make sense?.
>
 
For me divide, div, quo look equally good (or bad): the operation
is similar to division in rings, but different.  And all of them
are used in other parts: "div" is used in OutputForm.  Given that
I would just stick to 'divide'.

-- 
                              Waldek Hebisch
[email protected] 

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"FriCAS - computer algebra system" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to 
[email protected]
For more options, visit this group at 
http://groups.google.com/group/fricas-devel?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to