I am more focused on consistency since working with Sage, not because Sage is so consistent, but rather the opposite. ;-)
Because FriCAS/Axiom attempts to strongly encourages generic programming by polymorphism I think it is important to try to get the name right the first time or at least as soon as possible, otherwise we are stuck with an ever increasing number of unexpected and arcane usages. (Of course not that this is a particularly bad case but the point is this sort of thing does tend to accumulate.) Is there really no preferred *mathematical* term for this operation? On Thu, Oct 15, 2009 at 5:16 PM, Waldek Hebisch <[email protected]> wrote: >> ... But should we change 'div' to 'divide' in >> OrderedFreeMonoid or vice versa in in FreeMonoid. Given that 'divide' >> is used in three other places to return quotient and remainder, it >> seems to me that using 'div' might be more consistent Or maybe sense >> we already have 'rquo' and 'lquo' in both domains, maybe simply >> changing both 'div' and 'divide' to 'quo' would make sense?. >> > > For me divide, div, quo look equally good (or bad): the operation > is similar to division in rings, but different. And all of them > are used in other parts: "div" is used in OutputForm. Given that > I would just stick to 'divide'. > --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "FriCAS - computer algebra system" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.com/group/fricas-devel?hl=en -~----------~----~----~----~------~----~------~--~---
