> It seemse that we could just use divide as name of operation.
> Then we will re-use implementation from FreeMonoid.
I came to the same conclusion and was about to propose it.
We should rather change this line
"div": (%, %) -> Union(Record(lm: %, rm: %), "failed")
in the OrderedFreeMonoid definition to
divide: (%, %) -> Union(Record(lm: %, rm: %), "failed")
Just another pro for changing the category and reusing "divide".
In Aldor's libalgebra one finds
define EuclideanDomain: Category == GcdDomain with {
divide: (%, %) -> (%, %);
quo: (%, %) -> %;
rem: (%, %) -> %;
...
}
i.e. "divide" returns a tuple and "div" is no longer a keyword in Aldor.
Ralf
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups
"FriCAS - computer algebra system" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to
[email protected]
For more options, visit this group at
http://groups.google.com/group/fricas-devel?hl=en
-~----------~----~----~----~------~----~------~--~---