Ok, I don't know what happened with this...I reinstalled from scratch and i seems to be working now. I suspect perhaps because I started galaxy a few times before migrating to mysql. This time, I deleted everything, changed the config settings then started galaxy.

I'm now on to testing my cluster integration...so, I'm following this:


as my initial test. When I run the get flanks, I see the job get started on the cluster and errors out with the following error:

Traceback (most recent call last):
File "/home/galaxy/galaxy-dist/tools/new_operations/get_flanks.py", line 16, in ?
    from galaxy.tools.util.galaxyops import *
File "/home/galaxy/galaxy-dist/lib/galaxy/tools/__init__.py", line 15, in ?
    from galaxy import util, jobs, model
  File "/home/galaxy/galaxy-dist/lib/galaxy/jobs/__init__.py", line 4, in ?
    from galaxy import util, model
File "/home/galaxy/galaxy-dist/lib/galaxy/model/__init__.py", line 11, in ?
    import galaxy.datatypes.registry
File "/home/galaxy/galaxy-dist/lib/galaxy/datatypes/registry.py", line 6, in ? import data, tabular, interval, images, sequence, qualityscore, genetics, xml, coverage, tracks, chrominfo, binary, assembly, ngsindex File "/home/galaxy/galaxy-dist/lib/galaxy/datatypes/data.py", line 7, in ?
    import metadata
File "/home/galaxy/galaxy-dist/lib/galaxy/datatypes/metadata.py", line 5, in ?
    from galaxy.web import form_builder
  File "/home/galaxy/galaxy-dist/lib/galaxy/web/__init__.py", line 5, in ?
from framework import expose, json, json_pretty, require_login, require_admin, url_for, error, form, FormBuilder, expose_api File "/home/galaxy/galaxy-dist/lib/galaxy/web/framework/__init__.py", line 18, in ?
    import helpers
File "/home/galaxy/galaxy-dist/lib/galaxy/web/framework/helpers/__init__.py", line 29 return (content if len(content) <= length else content[:length].rsplit(' ', 1)[0]+suffix)
SyntaxError: invalid syntax

If I submit the job script from the shell, the job runs, but when the web interface submits the job it doesn't. In both cases, its the galaxy user account so I don't think environment variables are to blame.

On 2/18/11 10:26 AM, Ryan Golhar wrote:
Ryan, congratulations on getting this far!

Thank you! :)

Ok, so I think I have everything set up correctly. I'll test my
cluster integration tomorrow. For now, I can see galaxy from my web

First issue - When I go to User -> Login and try to log myself in
(I've already registered myself), it looks like it works, but the
browser get redirected really fast to another page, then again to
the main page. The User menu never shows me as logged in as it does
on the public usegalaxy.org <http://usegalaxy.org> site.

Is there a way to check that I'm actually logged in? If its not
showing, then I assume something is wrong. Where do I look to debug

Try hovering your mouse over the 'User' tab top right of the screen - if
you see 'logged in as ....' at the top of the popup, then you are
logged in. Otherwise not.

yeah, I'm definitely not logged in. Something isn't taking.

Also, if you have added your login email to the list of admin_users in
universe_wsgi.ini (and restarted galaxy of course...), then you can tell
you are logged in if you can see an 'Admin' tab - otherwise not.

No, I haven't done anything with admin stuff yet.

Depending on your situation, you may want to consider using external
authentication against (eg) an existing organizational
ldap/active_directory or other authentication database and have apache
pass the authentication headers through to a proxied galaxy. It's not
trivial but the benefit is that users have single sign on - one less
password to forget :)

I will, but first I want to get the default install working properly
before doing anything else.

SO....I've removed the Apache proxy and am hitting galaxy directly on
localhost:8080. Logging in still doesn't work. What else should I check?
I'm connected to a mySQL database running on a different server. Could
there be a problem there? paster.log doesn't seem to be much help in
debugging this...

To manage your subscriptions to this and other Galaxy lists, please use the 
interface at:


CONFIDENTIALITY NOTICE: This email communication may contain private, confidential, or legally privileged information intended for the sole use of the designated and/or duly authorized recipient(s). If you are not the intended recipient or have received this email in error, please notify the sender immediately by email and permanently delete all copies of this email including all attachments without reading them. If you are the intended recipient, secure the contents in a manner that conforms to all applicable state and/or federal requirements related to privacy and confidentiality of such information.

<<attachment: golharam.vcf>>

To manage your subscriptions to this and other Galaxy lists, please use the 
interface at:


Reply via email to