I can't see anything that would cause this behavior by looking at your logs, so 
I cannot answer what is causing this problem in your environment.  Basically it 
seems that nose is not finding any of the Python test scripts in the test 
subdirectory in your Galaxy installation directory, but I am not able to tell 
you why (I assume you haven't moved any directories).  

Sorry for not being of any help here.

Greg Von Kuster

On Feb 21, 2012, at 2:55 AM, Frank Sørensen wrote:

> Hi Greg,
> Den 20-02-2012 15:06, Greg Von Kuster skrev:
>> Hello Frank, see my inline comments.
>> On Feb 20, 2012, at 6:56 AM, Frank Sørensen wrote:
>>> Hi Guys,
>>> Sorry if this is a stupid question, but in order to find out which external 
>>> reference files (.loc - list files etc.) we need for our newly installed 
>>> Galaxy server, and to get an overview of which tools are in working order, 
>>> I have tried for a couple of days now, to run the script 
>>> "".
>> What is the exact command line that you are using to attempt to execute the 
>> functional tests?  Are you using the following?
>> %sh
> Yes, exactly - from .../galaxy-dist: ./
>>> I have copied tool_conf.xml over tool_conf.xml.sample,
>> The functional tests use tool_conf.xml.sample, so what are the contents of 
>> that file in your environment?
> It is the same as tool_conf.xml. The complete list of all the tools that come 
> with the Galaxy installation, plus our own.
>>> and I've tried to run all scripts mentioned in 
>> I assume by the above you mean this link:
> Yes ofcourse...
>> Here is another link that provide additional information for testing:
> Thanks, I'll check it out.
>>> I have tried to stop the server and run and all I 
>>> get is the message saying "Ran 0 tests in 0.000s", and an empty 
>>> run_functional_tests.html - file.
>>> I haven't been able to find any documentation to clarify this matter. Can 
>>> anyone give me a pointer please?
>> We'll need more information about your environment, but we'll get this 
>> figured out.
> %uname -a
> Linux moma 2.6.32-21-server #32-Ubuntu SMP Fri Apr 16 09:17:34 UTC 2010 
> x86_64 GNU/Linux
> I have attached the result of %lshw and the output from 
> and our global settings file.
>>> Our Galaxy server is installed using Mercurial on an Ubuntu server. I have 
>>> written tool-wrappers for some of our own programs, and they all work fine.
> Kind regards
> - Frank
> -- 
> Frank Sørensen, B.Sc., Programmer
> Molecular Diagnostic Laboratory (MDL)
> Molekylær Medicinsk Afdeling (MOMA)
> Århus Universitetshospital Skejby, Brendstrupgårdsvej, 8200 Århus N
> Tlf. +45 7845 5363
> <lshw.log><tests.log><universe_wsgi.ini><tool_conf.xml>

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

Reply via email to