Hello Galaxy Team/Users,

Thanks again for your great work.  A few months back I setup a local Galaxy 
server behind Nginx  and everything worked great except for the browser-based 
automatic-install of tools from Galaxy-main. Using the web interface I would 
click on "Install to local Galaxy" and get the following error message:

The resource could not be found. 
No route for /repository/Noneadmin_toolshed/install_repository

At the time I had absolutely no idea where the problem came from and the very  
helpful dev team assisted me in tracking the issue to a problem with the proxy 
configuration, however I was never able to resolve the issue despite tinkering 
with the proxy configuration. Since I need the proxy (on a computer with other 
web-facing services) and since  I could install tools using mercurial I didn't 
follow up the issue, however, automatic-install of tools would be great to 
have. A similar error is in the archives for someone using Apache 
(http://galaxy-development-list-archive.2308389.n4.nabble.com/Toolshed-not-accessible-td4096102.html
 ) and when I e-mailed the author he said he hadn't been able to resolve the 
issue and had simply worked around it as I had.  

As my Galaxy setup is very straightforward and follows the Galaxy Wiki 
instructions, I am thinking that others must have encountered this same 
problem, so here is my question:


1.  For users who have installed Galaxy and use either the Apache or Nginx 
proxy configuration from the Wiki, have you gotten the browser-based Automatic 
Install of toolshed tools to work?
2.  If so - could you share your proxy setup with me?

best,
zach cp


Zach Charlop-Powers
Post-Doctoral Fellow
Laboratory of Genetically Encoded Small Molecules
Rockefeller University

zchar...@rockefeller.edu

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to