Hi Everyone,

I installed a local instance of galaxy and some tools using the command
line, and for some reason liftover will work in the command line but won't
work in galaxy. Here's what I've done so far:

- Downloaded liftover standalone executable from the tool-dependencies page
in the Gwiki.

- Changed permissions on liftover executable to make it usable in the
command prompt (terminal, macosx) -> otherwise I get permission denied.

- Copied executable over to /usr/local/bin likewise to use in command
prompt and in Galaxy.

- Modified liftover.loc to include all the conversion types and directories
of chain.gz files I downloaded to use with the tool (I believe liftover can
make use of both .chain and .chain.gz files).

After that I tried to run liftover in Galaxy and it didn't work, giving me
some error that said hg19ToMm9 mapping is currently not available. It seems
to work fine using the command line though.

Since my goal is to setup galaxy locally, I really want to get this working
correctly. Can anyone guide me through what's gone wrong?
Also, there must be a better way of installing all these tools than
manually downloading every single one and using the command line, surely? I
had to type out the format of liftover.loc file manually for around 130
chain files... I'm convinced there has to be a better way.

Thanks in advance,

SJ
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to