Hi Dan,

The only thing I can think of that is causing this behavior is an apache 
rewrite rule that is not correctly handling your base URL.  That's the only 
scenario in which I've seen something like this occur, but others in the 
community may have seen other causes.  I'm fairly certain it has something to 
do with the server configuration (not a Galaxy issue).

Greg Von Kuster

On Aug 22, 2012, at 3:18 PM, Dan Sullivan wrote:

> I apologize for spamming this list, the screenshot that I specified as 
> "attached"  was supplied in a hyperlink farther down in the mail (not as an 
> attachment).
> 
> https://webshare.uchicago.edu/users/dansully/Public/Screen%20Shot%202012-08-21%20at%203.22.27%20PM.png
> 
> Dan
> 
> On Aug 22, 2012, at 10:13 AM, Dan Sullivan <dansulli...@gmail.com> wrote:
> 
>> Hi, Galaxy Developers,
>> 
>> I have a question that is very similar to the following thread;
>> 
>> http://dev.list.galaxyproject.org/Problem-fetching-updates-to-toolshed-tool-td4353417.html
>> 
>> Basically whenever I try to install a tool from the toolshed, it appears 
>> that a trailing slash is not appended to the Galaxy URL, which is causing a 
>> DNS lookup failure.  For example, the URL specified in the attached 
>> screenshot should be https://crigalaxy.uchicago.edu/admin_toolshed, however 
>> it is appearing as https://crigalaxy.uchicago.eduadmin_toolshed.    Does 
>> anybody know if there are any known bugs that would cause this behavior?  I 
>> might venture down the road of modifying 
>> lib/galaxy/webapps/community/controllers/repository.py as suggested by the 
>> thread above, although I would like to avoid doing this if possible.  I am 
>> seeing experiencing this behavior on the following version of Galaxy:
>> 
>> > hg parent
>> changeset:   7400:ec29ce8e27a1
>> 
>> In addition to this, I feel that its worthwhile to mention that I am using 
>> the apache proxy balancer with web scaling, however based on what I have 
>> seen and tested, I do not believe this (apache) to be the root cause of my 
>> problem.  The URL below is a screenshot of the network debug I am seeing 
>> from the firebug extension in firefox.
>> 
>> https://webshare.uchicago.edu/users/dansully/Public/Screen%20Shot%202012-08-21%20at%203.22.27%20PM.png
>> 
>> If somebody has seen this, or could offer a suggestion to bring this issue 
>> to resolve, I would definitely be interested in your strategy.  Thank-you so 
>> much for your help and for your time.
>> 
>> Dan Sullivan
>> 312-607-3702
> 
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
> 
>  http://lists.bx.psu.edu/

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to