Sorry Greg, I hadn't spotted your other questions there.

I'm fairly certain this must be a problem with the repository download I took 
as a .tar.gz from the main Galaxy Tool Shed: 
http://toolshed.g2.bx.psu.edu/repository/view_repository?id=ecc93bc8f0382e9e&changeset_revision=c2a356708570

I have tested this on a prior revision and the same error reoccurs.

I'm installing this clean for each test, to walk you through my process...

su - postgres
psql
postgres=# DROP DATABASE toolshed;
postgres=# CREATE DATABASE toolshed OWNER galaxy TEMPLATE template0;
postgres=# \q
exit

su - galaxy
cd toolshed/
hg clone http://www.bx.psu.edu/hg/galaxy galaxy-dist
cd galaxy-dist/
hg pull -u
cp ../../community_wsgi.ini .
chmod a+x ./*run*
./run.sh --daemon start; tail -F paster.log
./run.sh --daemon stop
./run_community.sh --daemon start; tail -F community_webapp.log


I access the Tool Shed and register my account, I access the Admin menu and 
create a category. I create a new repository and from there attempt to upload 
files to repository, selecting the .tar.gz previously downloaded from the link 
above. This is when I receive the error:

Module paste.exceptions.errormiddleware:143 in __call__
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  app_iter = self.application(environ, start_response)
Module paste.debug.prints:98 in __call__
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  environ, self.app)
Module paste.wsgilib:539 in intercept_output
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  app_iter = application(environ, replacement_start_response)
Module paste.recursive:80 in __call__
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  return self.application(environ, start_response)
Module paste.httpexceptions:632 in __call__
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  return self.application(environ, start_response)
Module galaxy.web.framework.base:160 in __call__
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  body = method( trans, **kwargs )
Module galaxy.web.framework:94 in decorator
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  return func( self, trans, *args, **kwargs )
Module galaxy.webapps.community.controllers.upload:184 in upload
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  set_repository_metadata_due_to_new_tip( trans, repository, 
>> content_alert_str=content_alert_str, **kwd )
Module galaxy.webapps.community.controllers.common:884 in 
set_repository_metadata_due_to_new_tip
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  error_message, status = set_repository_metadata( trans, repository, 
>> content_alert_str=content_alert_str, **kwd )
Module galaxy.webapps.community.controllers.common:833 in 
set_repository_metadata
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  updating_installed_repository=False )
Module galaxy.util.shed_util:706 in generate_metadata_for_changeset_revision
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  invalid_files_and_errors_tups = check_tool_input_params( app, files_dir, 
>> name, tool, sample_file_metadata_paths )
Module galaxy.util.shed_util:310 in check_tool_input_params
>>  
>> <http://galaxy-tools.nbi.ac.uk:9009/upload/upload?repository_id=7a78893ba4596583>
>>  if options.tool_data_table or options.missing_tool_data_table_name:
AttributeError: 'str' object has no attribute 'tool_data_table'


From: Greg Von Kuster [mailto:g...@bx.psu.edu]
Sent: 05 December 2012 13:43
To: Adam Carr (NBI)
Cc: galaxy-dev@lists.bx.psu.edu
Subject: Re: [galaxy-dev] Main toolshed broken??

ok, I'll wait on the additional information I requested.


On Dec 5, 2012, at 6:56 AM, Adam Carr (NBI) wrote:


Hi Greg,

Thank you for helping me out here.
I'm running on the galaxy-dist branch, changeset 8285:f364d992270c.

Many Thanks,
Adam.

From: Greg Von Kuster [mailto:g...@bx.psu.edu]
Sent: 05 December 2012 11:20
To: Adam Carr (NBI)
Cc: galaxy-dev@lists.bx.psu.edu<mailto:galaxy-dev@lists.bx.psu.edu>
Subject: Re: [galaxy-dev] Main toolshed broken??

Hi Adam,

I cannot help with this new issue without more information from you.  What 
version of Galaxy are you running?


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to