Users are getting the following error when trying to add a tool from the tool 
shed repository on our local galaxy instance.

"An error occurred. See the error logs for more information. (Turn debug on to 
display exception reports here)"

The galaxy server log shows the message included below. The main error is 
"ValueError: too many values to unpack ". From a similar previous post, the 
resolution was to use the latest code from Galaxy central. I just ran an "hg 
pull -u" pointing to galaxy-central (we had been pointing to galaxy-dist), but 
we still get the same error.

Any ideas?

(server log)
[29/Jan/2013:08:19:05 -0400] "GET 
/admin_toolshed/prepare_for_install?tool_shed_url=http://toolshed.g2.bx.psu.edu/&repository_ids=f19bc86bac946438&changeset_revisions=2d6671b10919
 HTTP/1.1" 500 - 
"http://toolshed.g2.bx.psu.edu/repository/preview_tools_in_changeset?repository_id=f19bc86bac946438&changeset_revision=2d6671b10919";
 "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.57.2 (KHTML, 
like Gecko) Version/5.1.7 Safari/534.57.2"
Error - <type 'exceptions.ValueError'>: too many values to unpack
URL: 
https://galaxy.its.unc.edu/admin_toolshed/prepare_for_install?tool_shed_url=http://toolshed.g2.bx.psu.edu/&repository_ids=f19bc86bac946438&changeset_revisions=2d6671b10919
File 
'/nas02/apps/galaxy-prod/galaxy-dist/eggs/Paste-1.6-py2.6.egg/paste/exceptions/errormiddleware.py',
 line 143 in __call__
  app_iter = self.application(environ, start_response)
File 
'/nas02/apps/galaxy-prod/galaxy-dist/eggs/Paste-1.6-py2.6.egg/paste/recursive.py',
 line 80 in __call__
  return self.application(environ, start_response)
File 
'/nas02/apps/galaxy-prod/galaxy-dist/lib/galaxy/web/framework/middleware/remoteuser.py',
 line 91 in __call__
  return self.app( environ, start_response )
File 
'/nas02/apps/galaxy-prod/galaxy-dist/eggs/Paste-1.6-py2.6.egg/paste/httpexceptions.py',
 line 632 in __call__
  return self.application(environ, start_response)
File '/nas02/apps/galaxy-prod/galaxy-dist/lib/galaxy/web/framework/base.py', 
line 160 in __call__
  body = method( trans, **kwargs )
File 
'/nas02/apps/galaxy-prod/galaxy-dist/lib/galaxy/web/framework/__init__.py', 
line 206 in decorator
  return func( self, trans, *args, **kwargs )
File 
'/nas02/apps/galaxy-prod/galaxy-dist/lib/galaxy/webapps/galaxy/controllers/admin_toolshed.py',
 line 1201 in prepare_for_install
  description, repository_clone_url, changeset_revision, ctx_rev, 
repository_owner, tool_dependencies = repo_info_tuple
ValueError: too many values to unpack


Mike Waldron
Systems Specialist
ITS - Research Computing Center
University of North Carolina at Chapel Hill

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to