I had stopped the Galaxy server before running the update, then started it 
afterward.


Mike Waldron
Systems Specialist
ITS - Research Computing Center
University of North Carolina at Chapel Hill

________________________________
From: Greg Von Kuster [g...@bx.psu.edu]
Sent: Tuesday, January 29, 2013 9:12 AM
To: Waldron, Michael H
Cc: galaxy-...@bx.psu.edu
Subject: Re: [galaxy-dev] Error trying to add tools from tool shed respository

Hi Michael,

Did you restart your Galaxy server after updating from Galaxy central?  Your 
paster log shows the following:

File 
'/nas02/apps/galaxy-prod/galaxy-dist/lib/galaxy/webapps/galaxy/controllers/admin_toolshed.py',
 line 1201 in prepare_for_install
  description, repository_clone_url, changeset_revision, ctx_rev, 
repository_owner, tool_dependencies = repo_info_tuple

However, that line no longer exists in the revision to which you've updated, 
and line 1201 of the admin_toolshed.py file is now:

status = kwd.get( 'status', 'done' )

Greg Von Kuster


On Jan 29, 2013, at 9:03 AM, Waldron, Michael H wrote:

Here is the output from hg heads.

[galaxy@galaxy galaxy-dist]$ hg heads
changeset:   8677:22788c1262a2
tag:         tip
user:        jeremy goecks 
<jeremy.goe...@emory.edu<mailto:jeremy.goe...@emory.edu>>
date:        Mon Jan 28 16:36:02 2013 -0500
summary:     Language improvements for tophat wrappers.

changeset:   7987:966a9b393b85
branch:      add_requirement_tags_for_plink
parent:      7472:06b31a61793c
user:        Dannon Baker <dannonba...@me.com<mailto:dannonba...@me.com>>
date:        Mon Aug 13 13:23:54 2012 -0400
summary:     Branch close

changeset:   7152:ffc20445b35e
branch:      split_blast2
parent:      7058:22f545c0d412
user:        Dannon Baker <dannonba...@me.com<mailto:dannonba...@me.com>>
date:        Wed Apr 18 07:59:38 2012 -0400
summary:     Branch close.

changeset:   7151:c94957ac5454
branch:      workflow_import_menu_api
parent:      6834:1a3d01b09f7a
user:        Dannon Baker <dannonba...@me.com<mailto:dannonba...@me.com>>
date:        Wed Mar 21 09:50:44 2012 -0400
summary:     Branch close for pull request.

changeset:   7150:314a10ae112d
branch:      split_blast
parent:      6757:ebf65c0b1e26
user:        Dannon Baker <dannonba...@me.com<mailto:dannonba...@me.com>>
date:        Tue Feb 28 12:32:54 2012 -0500
summary:     Close split_blast branch

changeset:   7149:1327f2219423
branch:      meme_requirement_on_fimo
parent:      6662:8ba74c17e809
user:        Daniel Blankenberg <d...@bx.psu.edu<mailto:d...@bx.psu.edu>>
date:        Fri Feb 03 11:15:29 2012 -0500
summary:     close branch


Mike Waldron
Systems Specialist
ITS - Research Computing Center
University of North Carolina at Chapel Hill

________________________________
From: Greg Von Kuster [g...@bx.psu.edu]
Sent: Tuesday, January 29, 2013 9:00 AM
To: Waldron, Michael H
Cc: galaxy-...@bx.psu.edu<mailto:galaxy-...@bx.psu.edu>
Subject: Re: [galaxy-dev] Error trying to add tools from tool shed respository

Hi Michael,

The previous post you mention is outdated.  The main Galaxy tool shed from 
which you are pulling has been tracking Galaxy dist for some time now, so you 
should only have to update to that.

However, the communication layer between Galaxy and the tool shed is backward 
compatible to the December 20, 2012 Galaxy release, so whether you have updated 
from Galaxy central or Galaxy dist, you should not be seeing the behavior you 
describe.

If you do, in fact, track Galaxy central though, and use the main Galaxy tool 
shed, you may experience some strange behavior because the the development code 
may include new features that are not available on the main tool shed since it 
tracks Galaxy dist.

What is the result of typing the following in your Galaxy installation 
directory?

hg heads

Thanks,

Greg Von Kuster


On Jan 29, 2013, at 8:38 AM, Waldron, Michael H wrote:

Users are getting the following error when trying to add a tool from the tool 
shed repository on our local galaxy instance.

"An error occurred. See the error logs for more information. (Turn debug on to 
display exception reports here)"

The galaxy server log shows the message included below. The main error is 
"ValueError: too many values to unpack ". From a similar previous post, the 
resolution was to use the latest code from Galaxy central. I just ran an "hg 
pull -u" pointing to galaxy-central (we had been pointing to galaxy-dist), but 
we still get the same error.

Any ideas?

(server log)
[29/Jan/2013:08:19:05 -0400] "GET 
/admin_toolshed/prepare_for_install?tool_shed_url=http://toolshed.g2.bx.psu.edu/&repository_ids=f19bc86bac946438&changeset_revisions=2d6671b10919
 HTTP/1.1" 500 - 
"http://toolshed.g2.bx.psu.edu/repository/preview_tools_in_changeset?repository_id=f19bc86bac946438&changeset_revision=2d6671b10919";
 "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.57.2 (KHTML, 
like Gecko) Version/5.1.7 Safari/534.57.2"
Error - <type 'exceptions.ValueError'>: too many values to unpack
URL: 
https://galaxy.its.unc.edu/admin_toolshed/prepare_for_install?tool_shed_url=http://toolshed.g2.bx.psu.edu/&repository_ids=f19bc86bac946438&changeset_revisions=2d6671b10919
File 
'/nas02/apps/galaxy-prod/galaxy-dist/eggs/Paste-1.6-py2.6.egg/paste/exceptions/errormiddleware.py',
 line 143 in __call__
  app_iter = self.application(environ, start_response)
File 
'/nas02/apps/galaxy-prod/galaxy-dist/eggs/Paste-1.6-py2.6.egg/paste/recursive.py',
 line 80 in __call__
  return self.application(environ, start_response)
File 
'/nas02/apps/galaxy-prod/galaxy-dist/lib/galaxy/web/framework/middleware/remoteuser.py',
 line 91 in __call__
  return self.app( environ, start_response )
File 
'/nas02/apps/galaxy-prod/galaxy-dist/eggs/Paste-1.6-py2.6.egg/paste/httpexceptions.py',
 line 632 in __call__
  return self.application(environ, start_response)
File '/nas02/apps/galaxy-prod/galaxy-dist/lib/galaxy/web/framework/base.py', 
line 160 in __call__
  body = method( trans, **kwargs )
File 
'/nas02/apps/galaxy-prod/galaxy-dist/lib/galaxy/web/framework/__init__.py', 
line 206 in decorator
  return func( self, trans, *args, **kwargs )
File 
'/nas02/apps/galaxy-prod/galaxy-dist/lib/galaxy/webapps/galaxy/controllers/admin_toolshed.py',
 line 1201 in prepare_for_install
  description, repository_clone_url, changeset_revision, ctx_rev, 
repository_owner, tool_dependencies = repo_info_tuple
ValueError: too many values to unpack


Mike Waldron
Systems Specialist
ITS - Research Computing Center
University of North Carolina at Chapel Hill

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

 http://lists.bx.psu.edu/



___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

  http://lists.bx.psu.edu/

Reply via email to