My goal is that no user can upload or create a total of more than 100 gb.

So I tried following the instructions here to set up a quota:

I turned on these two things in universe_wsgi.ini:

 enable_quotas = True
allow_user_dataset_purge = True

And then tried to set up a quota like this:

When I clicked save i got a server error.  I see this in the galaxy log file:

WSGI Variables
  application: <paste.recursive.RecursiveMiddleware object at 0x858b8d0>
  paste.cookies: (<SimpleCookie:
  paste.expected_exceptions: [<class 'paste.httpexceptions.HTTPException'>]
  paste.httpexceptions: <paste.httpexceptions.HTTPExceptionHandler
object at 0x858b550>
  paste.httpserver.thread_pool: <paste.httpserver.ThreadPool object at
  paste.recursive.forward: <paste.recursive.Forwarder from />
  paste.recursive.include: <paste.recursive.Includer from />
  paste.recursive.include_app_iter: <paste.recursive.IncluderAppIter from />
  paste.recursive.script_name: ''
  paste.throw_errors: True
  webob._parsed_post_vars: (MultiDict([('name', 'General'),
('description', 'General User Quota'), ('amount', '100 gb'),
('operation', '='), ('default', 'registered'), ('create_quota_button',
'Save')]), <FakeCGIBody at 7f3c3ce18950 viewing
  webob._parsed_query_vars: (MultiDict([]), '')
  wsgi process: 'Multithreaded'
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

Reply via email to