On Monday, April 22, 2013, Greg Von Kuster wrote:

>
> On Apr 22, 2013, at 2:01 PM, Dave Bouvier wrote:
>
> > On 4/22/13 13:31:28.000, Peter Cock wrote:
> >> On Mon, Apr 22, 2013 at 6:24 PM, Dave Bouvier 
> >> <d...@bx.psu.edu<javascript:;>>
> wrote:
> >>> Peter,
> >>>
> >>> I noticed that the 'version' attribute of the install tag is set to
> '0.0.1',
> >>> while the code currently only supports a version attribute of 1.0.
> When I
> >>> duplicated the tool dependency xml locally and changed the version tag
> to:
> >>>
> >>>         <install version="1.0">
> >>>
> >>
> >> Do you mean it literally only looks for the string "1.0", which would
> >> make sense if this is referring the the XML mini-language the
> >> Galaxy Tool Shed is using (and not as I assumed the version
> >> of the installation script)?
> >
> > Yes, that is the current behavior, see
> http://wiki.galaxyproject.org/ToolShedToolFeatures#Supported_tags_sets_for_the_tool_dependencies.xml_file_.28as_of_February_6.2C_2013.29
> >
> > Specifically the row that describes the <install> tag.


Yes, now that I've read that it is clear :)


> >
> >>
> >> Could you update the installation code to treat anything else
> >> as an error?
> >
> > Greg is currently in the process of updating the code to handle that
> situation.
>
>
>
> This is the new behavior as of change set 9504:ea0b7ca55aec, which is now
> available on the test tool shed.
>
>
Great.

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to