Okay! I found out what the issue was. I am not sure if this is related to
the new Galaxy setup (requiring job_conf.xml) but, I added the following
lines to my universe_wsgi.ini, saved, restarted and it worked.

   drmaa_external_runjob_script = scripts/drmaa_external_runner.py
   drmaa_external_killjob_script = scripts/drmaa_external_killer.py
   external_chown_script = scripts/external_chown_script.py


So the bigger question is:
Is the current documentation wrong and adding drmaa to the job_conf.xml
incorrect?
    If not, then what I am doing wrong in my file?

Thanks,
-Adam

--
Adam Brenner
Computer Science, Undergraduate Student
Donald Bren School of Information and Computer Sciences

Research Computing Support
Office of Information Technology
http://www.oit.uci.edu/rcs/

University of California, Irvine
www.ics.uci.edu/~aebrenne/
aebre...@uci.edu


On Tue, Apr 23, 2013 at 10:47 AM, Adam Brenner <aebre...@uci.edu> wrote:

> Anyone have any ideas as to why its not running? Surely must be a few
> users who run Galaxy via a Scheduler using DRMAA...
>
> My updated job_conf.xml is like so: http://pastebin.com/raw.php?i=QJbay57i
>
>
> Jobs do get submitted to DRMAA, but the scripts are never called to run as
> real user. I have DEBUG set to true in universe_wsgi.ini and nothing
> regarding errors or debug message are created in paster.log about this.
>
> --
> Adam Brenner
> Computer Science, Undergraduate Student
> Donald Bren School of Information and Computer Sciences
>
> Research Computing Support
> Office of Information Technology
> http://www.oit.uci.edu/rcs/
>
> University of California, Irvine
> www.ics.uci.edu/~aebrenne/
> aebre...@uci.edu
>
>
> On Tue, Apr 16, 2013 at 4:55 PM, Adam Brenner <aebre...@uci.edu> wrote:
>
>> I have the following job_conf.xml file setup for our cluster:
>> http://pastebin.com/raw.php?i=0uNhcVJk
>>
>> When running jobs from my admin account via Galaxy it runs under the same
>> user as galaxy is, for testing, this as root. I need for it to run under
>> the real user.
>>
>> The email address / galaxy account I am using to test with does match
>> with a user on the cluster -- u...@example.com where user is a valid
>> user account with correct permissions to run jobs on our cluster and queue.
>>
>> I followed the information here:
>> http://wiki.galaxyproject.org/Admin/Config/Performance/Cluster#Submitting_Jobs_as_the_Real_User
>>
>> Any ideas as to why galaxy_external* is not being called? The paster.log
>> file does not show anything useful regarding calling external scripts.
>>
>> --
>> Adam Brenner
>> Computer Science, Undergraduate Student
>> Donald Bren School of Information and Computer Sciences
>>
>> Research Computing Support
>> Office of Information Technology
>> http://www.oit.uci.edu/rcs/
>>
>> University of California, Irvine
>> www.ics.uci.edu/~aebrenne/
>> aebre...@uci.edu
>>
>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to