Thanks and it worked!

 From: Dannon Baker <dannon.ba...@gmail.com>
To: Kathryn Sun <kathryn....@ymail.com> 
Cc: "galaxy-dev@lists.bx.psu.edu" <galaxy-dev@lists.bx.psu.edu> 
Sent: Friday, May 10, 2013 10:07 AM
Subject: Re: Error with fastqc

Hi Kathryn,

It looks like you haven't installed FastQC (or potentially installed it and 
just haven't made it accessible to Galaxy).  You'll need to install FastQC from 
http://www.bioinformatics.babraham.ac.uk/projects/fastqc/ if you haven't 
already, and the main fastqc perl script must be executable from 

For dependencies like this, you can usually look at 
http://wiki.galaxyproject.org/Admin/Tools/Tool%20Dependencies for a few 

Good luck,


On Thu, May 9, 2013 at 9:43 AM, Kathryn Sun <kathryn....@ymail.com> wrote:

>I've set up galaxy at the local linux. After data configuration, I run 
fastqc to check how it runs. Here I got error message as below --  
 error occurred running this job: Traceback (most recent call last): 
File "../galaxy-dist/tools/rgenetics/rgFastQC.py", line 158, in assert 
os.path.isfile(opts.executable),'##rgFastQC.py error - cannot find 
executable %s' % opts.executable AssertionError: ##r
>Here is the detail of the error --
>Tool: FastQC:Read QC
>Name:    FastQC_FASTQ Groomer on data 6.html
>Created:    May 02, 2013
>Filesize:    0 bytes
>Dbkey:    mm9
>Format:    html
>Tool Version:    
>Tool Standard Output:    stdout
>Tool Standard Error:    stderr
>Tool Exit Code:    1
>Input Parameter     Value
>Short read data from your current history     8: FASTQ Groomer on data 6
>Title for the output file - to remind you what the job was for     FastQC
>Contaminant list     No
>What might be the problem? Thank you!
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to