Hi Greg,

The strange thing is that the tool loads fine in my local Galaxy server (so not 
using toolshed but the old-fashioned way). The difference could be that my 
Galaxy server is not up to date and perhaps using a different xml parsing 
scheme? 

Anyway, are there XSD files which I could use to run some more detailed 
validations?

Thanks,

Pieter.

-----Original Message-----
From: Greg Von Kuster [mailto:g...@bx.psu.edu] 
Sent: dinsdag 29 oktober 2013 13:29
To: Lukasse, Pieter
Cc: galaxy-...@bx.psu.edu Dev
Subject: Re: [galaxy-dev] Tool refuses to appear in Toolshed package contents

Hi Pieter,

The tool shed is undoubtedly not the problem here.  The tool is simply not 
identified as a Galaxy tool for some reason.  When it had xml validation 
errors, it was not loaded as a Galaxy tool due to the errors.  I'm not sure 
what new issue is causing the xml to not load properly as a Galaxy tool.  But 
Peter's direction is correct - discover why the xml file is not properly 
loading into Galaxy as a Galaxy tool.  The Tool Shed uses virtually the same 
loading process as Galaxy.  I'm travelling currently, but I'll try to get some 
time ove rhte next couple of days to look at this again if you haven't been 
able to discover the cause of the problem.

Thanks,

Greg Von Kuster


On Oct 29, 2013, at 7:00 AM, Peter Cock <p.j.a.c...@googlemail.com> wrote:

> On Tue, Oct 29, 2013 at 6:23 AM, Lukasse, Pieter <pieter.luka...@wur.nl> 
> wrote:
>> Hi Greg,
>> 
>> what I mean is that I don't expect any other errors in my files since 
>> I corrected the errors you reported. When using my XML editor I also 
>> don't get any errors, so the files seem OK. However, the problem
>> remains: one of the tools and also the dependencies definitions don't 
>> appear in the toolshed package. Are there .xsd files I can check 
>> these files against?
> 
> As far as I know there are no XML schema definitions for the Galaxy 
> tool definition format (e.g. DTD files), so this cannot be fully 
> validated by an XML validator.
> 
> As your problem, according to the Tool Shed you have four valid tools:
> http://testtoolshed.g2.bx.psu.edu/view/pieterlukasse/prims_masscomb
> 
> * MsPicture
> * FASTA validator
> * DB Search Converter
> * Mascot
> 
> The missing (invalid) tool is masscomb_dbsearch_xtandem.xml - X 
> Tandem. Does the tool work on your local Galaxy instance?
> If so then it seems the Tool Shed is being too strict, or failing to 
> parse this tool for some reason.
> 
> Peter
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this and other 
> Galaxy lists, please use the interface at:
> http://lists.bx.psu.edu/
> 
> To search Galaxy mailing lists use the unified search at:
> http://galaxyproject.org/search/mailinglists/




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to