Hello all,

While attempting a fresh Galaxy install from both galaxy-central and
galaxy-dist, I ran into a problem initialising the default SQLite database
(database/universe.sqlite),

$ hg clone https://bitbucket.org/galaxy/galaxy-dist
...
$ cd galaxy-dist
$ ./run.sh
...
galaxy.model.migrate.check DEBUG 2013-10-31 10:28:26,143 pysqlite>=2
egg successfully loaded for sqlite dialect
Traceback (most recent call last):
...
OperationalError: (OperationalError) database is locked u'PRAGMA
table_info("dataset")' ()

After some puzzlement, I realised this was down to the file system -
I was trying this under my home directory mounted via a distributed
file system (gluster I think).

Repeating the experiment under /tmp on a local hard disk worked :)

(I'm posting this message for future reference; hopefully Google and/or
mailing list searches will help anyone else facing this error)

Regards,

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to