On Mon, Feb 24, 2014 at 12:03 PM, Greg Von Kuster <g...@bx.psu.edu> wrote:
> Hello Peter,
>
> We've eliminated the use of fabric for installing tool dependencies on the
> test tool shed, and with this change I've seen the test tool shed fail at
> the same point the past 3 runs.  It fails attempting to compile boost where
> it times out ( we have abuildbot timeout set at 36000 seconds if nothing
> occurs).  This error occurs about half way through Stage 1 of the test run,
> so about 1/2 of the tool dependency definition repositories are not tested
> and no tests are run for repositories with tools.

Ah. So the apparently random split in behaviour for the BLAST+
packages may just be down to if they were in the first or second
half of the repositories?

> The following log shows the repeaated compilation error.  We'll be
> investigating approaches for handling issues like this.  Now that we've
> eliminated fabric we'll have many more options for handling installation
> issues like this.  Of course, if it turns out that our new code that
> eliminated fabric caused this, we'll get a fix in.

If push comes to shove, you could declare BOOST an expected
library to be pre-installed?
https://wiki.galaxyproject.org/Admin/Config/ToolDependenciesList

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to