Just wondering if I can still use the following to fix up my messed up tophat2 
install (the install had hung up on me, for 2 hours, and I tried to 
remove/repair it via the interface).  I haven't had problems installing any 
other tools or packages.  I am using postgres but this advice was given 2 years 
ago to another user and fields may have changed.  Thanks for any help!

1. Manually remove the installed repository subdirectory hierarchy from disk.
2. If the repository included any tools, manually remove entries for each of 
them from the shed_tool-conf.xml file ( or the equivalent file you have 
configured for handling installed repositories )
3. Manually update the database using the following command (assuming your 
installed repository is named 'bcftools_view' and it is the only repository you 
have installed with that name) - letter capitalization is required:

The following assumes you're using postgres:

update tool_shed_repository set deleted=True, uninstalled=True, 
status='Uninstalled', error_message=Null  where name = 'bcftools_view';

From: Briand, Sheldon
Sent: Wednesday, March 12, 2014 11:44 AM
To: galaxy-dev@lists.bx.psu.edu
Subject: tophat2 install


I ran into a problem installing tophat2 here:
tophat2 version 2.0.9: coercing to Unicode: need string or buffer, NoneType 

I have only used the interface to do the installation (no manual deletes).  The 
rest of the dependencies for tophat2 installed just fine.

Repairing the repository doesn't make any difference.


Sheldon Briand
NRC Research Computing Support Analyst
Research Computing Support / Soutien Informartique a la Recherche
Operations, Science Portfolio / Operations, Portefeuil des sciences
Rm 329A, 1411 Oxford Street / Piece 329A, 1411 Rue Oxford
Halifax, NS  B3H 3Z1
902 426-1677

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to