Hello Janaki and Björn,

This problematic behavior is a result of a bug in the repository export process 
which has been fixed in the following changeset which is currently available in 
the Galaxy central repo.  Thanks very much for reporting this.

https://bitbucket.org/galaxy/galaxy-central/commits/773578e65580e3488fadc144739d82f86d9b30f3

Greg Von Kuster

On Apr 3, 2014, at 7:53 AM, Greg Von Kuster <g...@bx.psu.edu> wrote:

> Yes, if that is the behavior, that is definitely a bug.  I'll take a look and 
> get back to you on this.
> 
> Thanks!
> 
> On Apr 3, 2014, at 7:35 AM, Björn Grüning <bjoern.gruen...@gmail.com> wrote:
> 
>> Hi JanakiRam,
>> 
>> I will take Greg into CC. He is the main Tool Shed developer, maybe we 
>> spotted a bug in populating "prior_installation_required" in 
>> repository_dependencies.xml file. He probably knows if that is supposed to 
>> work.
>> 
>> Greg, to summarize our findings. It seems that if JanakiRam uploads a 
>> repository_dependencies.xml file into a local toolshed the 
>> "prior_installation_required='False'" will be inserted. If he tries to 
>> install it, Galaxy complains about a wrong syntax inside the 
>> repository_dependecies.xml file. Imho "prior_installation_required" does not 
>> make sense in repository_dependencies.xml or? Is that an bug?
>> 
>> JanakiRam can you confirm my summary?
>> 
>> Thanks,
>> Bjoern
>> 
>> Am 03.04.2014 12:49, schrieb Janaki Rama Rao Gollapudi:
>>> Hi,
>>> 
>>> I am using latest checkout from
>>> https://bitbucket.org/galaxy/galaxy-dist/(Just now I also updated my
>>> local galaxy code base).  Yes, without
>>> repository dependency everything working fine.
>>> 
>>> Thanks,
>>> JanakiRam
>>> 
>>> 
>>> 
>>> On Thu, Apr 3, 2014 at 3:39 PM, Björn Grüning 
>>> <bjoern.gruen...@gmail.com>wrote:
>>> 
>>>> Hi,
>>>> 
>>>> I just tested it in the test-toolshed and for me
>>>> 'prior_installation_required' is not inserted. Which Galaxy version do you
>>>> use? Please note, that I'm not sure if that is really causing the trouble
>>>> you have seen.
>>>> If you remove the repository dependency everything is working as expected?
>>>> 
>>>> 
>>>> 
>>>> Am 03.04.2014 12:01, schrieb Janaki Rama Rao Gollapudi:
>>>> 
>>>> Hi Bjoern,
>>>>> 
>>>>> Please see my comments inline.
>>>>> 
>>>>> On Thu, Apr 3, 2014 at 3:14 PM, Björn Grüning <bjoern.gruen...@gmail.com>
>>>>> wrote:
>>>>> 
>>>>> Hi Janaki,
>>>>>> 
>>>>>> can you try to remove this prior_installation_required completely?
>>>>>> 
>>>>>> 
>>>>>       I didn't added 'prior_installation_required' in the
>>>>> repository_dependencies.xml(as this is optional), it got added when I
>>>>> exported repository files from tool shed. Actual
>>>>> repository_dependencies.xml file has below content.
>>>>> 
>>>>> <?xml version="1.0"?>
>>>>> <repositories description="test description">
>>>>>     <repository name="string_occurrence" owner="janakiram-t1" />
>>>>> </repositories>
>>>>> 
>>>>> 
>>>>> Also why do you need a repository dependency, I think that is not needed
>>>>>> or?
>>>>>> 
>>>>>> 
>>>>>          This is the first time I working with repository dependencies,
>>>>> so
>>>>> for testing I am trying to add simple repository dependency to my custom
>>>>> tool.
>>>>> 
>>>>> 
>>>>>> Cheers,
>>>>>> Bjoern
>>>>>> 
>>>>>> Am 03.04.2014 09:30, schrieb Janaki Rama Rao Gollapudi:
>>>>>> 
>>>>>> Hi Bjoern,
>>>>>> 
>>>>>>> 
>>>>>>> I also exported both the repositories from local toolshed. Please find
>>>>>>> the
>>>>>>> attached files.
>>>>>>> 
>>>>>>> 
>>>>>>> Thanks,
>>>>>>> JanakiRam
>>>>>>> 
>>>>>>> 
>>>>>>> On Thu, Apr 3, 2014 at 12:50 PM, Janaki Rama Rao Gollapudi <
>>>>>>> janakiram.gollap...@india.semanticbits.com> wrote:
>>>>>>> 
>>>>>>> Hi,
>>>>>>> 
>>>>>>>> 
>>>>>>>> Thanks for quick reply. Please find the attached .tar file of both the
>>>>>>>> repositories.
>>>>>>>> 
>>>>>>>> 
>>>>>>>> Thanks,
>>>>>>>> JanakiRam
>>>>>>>> 
>>>>>>>> 
>>>>>>>> On Thu, Apr 3, 2014 at 12:45 PM, Björn Grüning <
>>>>>>>> bjoern.gruen...@gmail.com>wrote:
>>>>>>>> 
>>>>>>>> This all seems to be fine, can you send me a tarball with both
>>>>>>>> 
>>>>>>>>> repositories ...
>>>>>>>>> 
>>>>>>>>> Thanks,
>>>>>>>>> Bjoern
>>>>>>>>> 
>>>>>>>>> Am 03.04.2014 09:05, schrieb Janaki Rama Rao Gollapudi:
>>>>>>>>> 
>>>>>>>>> Hi,
>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>> Did anyone faced this issue ?. I struck here. Please suggest me.
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>> Thanks,
>>>>>>>>>> JanakiRam
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>> On Wed, Apr 2, 2014 at 3:10 PM, Janaki Rama Rao Gollapudi <
>>>>>>>>>> janakiram.gollap...@india.semanticbits.com> wrote:
>>>>>>>>>> 
>>>>>>>>>>  Hi,
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>>> I have implemented a custom tool called 'barcode-parse' and uploaded
>>>>>>>>>>> this
>>>>>>>>>>> custom to into my local tool shed(which is running at
>>>>>>>>>>> http://localhost:9009). Also able to install this custom tool from
>>>>>>>>>>> galaxy.
>>>>>>>>>>> 
>>>>>>>>>>> Then I have added simple repository dependency. I have created a xml
>>>>>>>>>>> file
>>>>>>>>>>> 'repository_dependencies.xml'. Then I created a new repository in
>>>>>>>>>>> the
>>>>>>>>>>> toolShed called 'Test' and uploaded all necessary files(.py,
>>>>>>>>>>> definition
>>>>>>>>>>> xml
>>>>>>>>>>> file and repository dependency xml file) into this repository. (I
>>>>>>>>>>> have
>>>>>>>>>>> created another repository called 'string_occurrence' and uploaded
>>>>>>>>>>> necessary files into toolShed which is used as dependency
>>>>>>>>>>> repository)
>>>>>>>>>>> 
>>>>>>>>>>> <?xml version="1.0"?>
>>>>>>>>>>> <repositories description="">
>>>>>>>>>>>       <repository toolshed="http://localhost:9009";
>>>>>>>>>>> name="string_occurrence" owner="janakiram-t1" />
>>>>>>>>>>> </repositories>
>>>>>>>>>>> 
>>>>>>>>>>> I tried to install custom tool 'barcode-parse' from galaxy, but I
>>>>>>>>>>> got
>>>>>>>>>>> below error message.
>>>>>>>>>>> 
>>>>>>>>>>> The repository dependency definitions for this repository are
>>>>>>>>>>> invalid
>>>>>>>>>>> and
>>>>>>>>>>> will be ignored.
>>>>>>>>>>> 
>>>>>>>>>>> I followed the steps mentioned in the galaxy wiki<https://wiki.
>>>>>>>>>>> galaxyproject.org/SimpleRepositoryDependencies>
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> Am I doing anything wrong? Please suggest me on this.
>>>>>>>>>>> 
>>>>>>>>>>> Thanks,
>>>>>>>>>>> JanakiRam
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>> ___________________________________________________________
>>>>>>>>>> Please keep all replies on the list by using "reply all"
>>>>>>>>>> in your mail client.  To manage your subscriptions to this
>>>>>>>>>> and other Galaxy lists, please use the interface at:
>>>>>>>>>>    http://lists.bx.psu.edu/
>>>>>>>>>> 
>>>>>>>>>> To search Galaxy mailing lists use the unified search at:
>>>>>>>>>>    http://galaxyproject.org/search/mailinglists/
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>>>> 
>>>>>>>> 
>>>>>>> 
>>>>> 
>>> 
>> ___________________________________________________________
>> Please keep all replies on the list by using "reply all"
>> in your mail client.  To manage your subscriptions to this
>> and other Galaxy lists, please use the interface at:
>> http://lists.bx.psu.edu/
>> 
>> To search Galaxy mailing lists use the unified search at:
>> http://galaxyproject.org/search/mailinglists/
>> 
> 
> 
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>  http://lists.bx.psu.edu/
> 
> To search Galaxy mailing lists use the unified search at:
>  http://galaxyproject.org/search/mailinglists/
> 


___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to