Hi folks,

Having a difficult time with coding the "configure" step in this new 
tool_dependency.xml file, namely that an error "/bin/sh: configure: command not 
found" results when I try to install my beta development tool from a local test 
toolshed (which is downloading and installing other tools just fine).  

<actions>
        <action type="shell_command">git clone 
https://github.com/myuser/mygitstuff.git .</action>
        <action type="shell_command">git reset --hard 
1819482db93bf0025c2588b5264cc0ec8c61029c</action> 
        <action type="shell_command">configure --disable-gui 
--prefix=$INSTALL_DIR</action>                             
        <action type="make_install"></action>
                <action type="move_directory_files">
                        <source_directory>bin</source_directory>
                        
<destination_directory>$INSTALL_DIR/bin</destination_directory>
                </action>
                <action type="set_environment">
                        <environment_variable name="PATH" 
action="prepend_to">$INSTALL_DIR/bin</environment_variable>
                </action>
        </actions>

Any hints about why this isn't being found or what the /bin/sh needs to get it 
going?
When I do a git reset --hard, the "configure" file is definitely there, with 
executable flag set.  Any other permission oddities?

I've also tried <action type="autoconf"></action> , which yeilds same error.  
(Skipping that line and doing <action type="make_install"></action> at least 
finds and runs "make", though it errors out for lack of input data).

Regards,

Damion

Hsiao lab, BC Public Health Microbiology & Reference Laboratory, BC Centre for 
Disease Control
655 West 12th Avenue, Vancouver, British Columbia, V5Z 4R4 Canada

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to