On Thu, Jul 31, 2014 at 12:29 PM, Peter Cock <p.j.a.c...@googlemail.com> wrote:
> On Thu, Jul 31, 2014 at 5:21 PM, bjoern.gruen...@googlemail.com
> <bjoern.gruen...@gmail.com> wrote:
>> Hi Peter,
>>
>>
>> 2014-07-31 10:57 GMT+02:00 Peter Cock <p.j.a.c...@googlemail.com>:
>>
>>> Hi Dave,
>>>
>>> You are right that on closer inspection I've mixed tool_dependencies.xml
>>> and repository_dependencies.xml *again*. Evidentially my mental model
>>> does not match Greg's here:
>>>
>>> (*) I need to define a tool installation recipe for something not in the
>>> Tool Shed --> write an install script called tool_dependencies.xml
>>>
>>> (*) I need to depend on a Python package by pointing at another repository
>>> in the Tool Shed --> repository_dependencies.xml
>>
>> I might be wrong, but I think that also goes to tool_dependencies.xml
>
> Correct, e.g.
> https://github.com/peterjc/pico_galaxy/tree/master/tools/seq_select_by_id
>
> Thanks!
>
>>>
>>> (*) I need to depend on a datatype package by pointing at another
>>> repository in the Tool Shed --> repository_dependencies.xml
>>>
>>> (*) I need to depend on a binary package by pointing at another repository
>>> in the Tool Shed --> repository_dependencies.xml ? No. You need
>>> tool_dependencies.xml for this too
>>
>> As far as I understood, everything that is referenced in the tool.xml under
>> the requirement section, needs to be in a tool_dependencies.xml file. Any
>> other dependency are from the repository (data_types, data_manager,
>> workflows ...).
>>
>> Ciao,
>> Bjoern
>
> Sure, there is a logic here - but its a definition which I seem to still
> struggle with :(
>
>>> But that aside, the test framework error here is completely unhelpful.
>>>
>>> Why is there no error message about missing a dependency?
>>> Was there an error from running my tool which was not shown?
>>>
>>> Thanks,
>>>
>>> Peter
>
> I'd still like to get a more explicit error from the test suite than
> "History in error state" though ;)

Yes - that is problematic.

Dave B - can we set GALAXY_TEST_VERBOSE_ERRORS to "True" in the
environment of the install and test framework? I disabled it by
default because it causes to sqlite to fallover rather frequently -
but if install and test framework is backed by a postgres database
this is probably not a problem.

-John

>
> Regards,
>
> Peter
> ___________________________________________________________
> Please keep all replies on the list by using "reply all"
> in your mail client.  To manage your subscriptions to this
> and other Galaxy lists, please use the interface at:
>   http://lists.bx.psu.edu/
>
> To search Galaxy mailing lists use the unified search at:
>   http://galaxyproject.org/search/mailinglists/
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to