I'm running the bgruening/galaxy-stable docker image. After making some
changes to the tools, I can no longer upload workflows. How do I debug?

What I get from the server is
Internal Server Error Galaxy was unable to successfully complete your

An error occurred.
This may be an intermittent problem due to load or other unpredictable
factors, reloading the page may address the problem.

*The error has been logged to our team.*
Since I am 'our team', I'd like to find out how to see the log! None of the
logs under /home/galaxy indicate a problem (that I notice), but uwsgi.log
does list a GET command for the workflow:
[28/Jul/2015:16:31:50 +0000] "GET /api/datatypes?extension_only=False&
HTTP/1.1" 200 - "";
"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0"

I figured it was an issue with the workflow, so I created a simple workflow
on the same galaxy instance. When I tried to download the workflow file, I
got the exact same error.

Restarting the instance (several times) didn't help.

How do I get more info on these errors?


Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to