Hi there (sorry for all theses questions),

when I execute a job with remote user drmaa configuration on our pbs cluster, I see in the job working directory the script the galaxy_XXX.sh which set the galaxy virtual env and execute set_metadata.py after tool_script.sh completion but I get this in cluster error output :

python: /lib64/libz.so.1: no version information available (required by python)
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Traceback (most recent call last):
File "galaxy/database/job_working_directory/002/2824/set_metadata_tkCRRk.py", line 1, in <module> from galaxy_ext.metadata.set_metadata import set_metadata; set_metadata() File "galaxy/galaxy/lib/galaxy_ext/metadata/set_metadata.py", line 15, in <module>
    import json
ImportError: No module named json

The tool is execution is ok but the metadata script failed, but as that script is executed on the cluster and not on galaxy server, (I think) the virtual env is not properly set.

Is there a way to remove set_metadata from galaxy_XXX.sh script as It was in v16.01 ? I don't really understand what to set in galaxy.ini (I tried to set retry_metadata_internally to True and then False but I get the same result).

Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:

To search Galaxy mailing lists use the unified search at:

Reply via email to