?Hi, Sarah,

I can't be of much help on the tools issue but the "Request-URI Too Large" 
error can be fixed by adding a line like :


LimitRequestFieldSize 12392


(the size is a number of bytes which reflects the length of the uri eventually. 
For my setup, the above number does the job)


This line shall be added into your httpd.conf of ssl.conf in case you are using 
https connection. It shall be placed within


<VirtualHost *: ... >
        ?here

</VirtualHost>


Cheers


Nikolay

===============
Nikolay Vazov, PhD
Department for Research Computing, University of Oslo
________________________________
From: galaxy-dev <galaxy-dev-boun...@lists.galaxyproject.org> on behalf of 
Sarah DIEHL <sarah.di...@uni.lu>
Sent: 20 July 2016 09:51
To: galaxy-dev@lists.galaxyproject.org
Subject: [galaxy-dev] errors when updating tools

Hi,

I just updated our Galaxy from 15.10 to 16.04. I also wanted to update the 
tools installed, but I'm (again) getting a whole bunch of different errors.


Some of the updated tools rely on package_cairo_1_12_14, which fails, because 
it cannot find some of it's dependencies (see package_cairo_errors.jpg):

> Error installing tool dependency fontconfig version 2.11.1: Unable to locate 
> required tool shed repository named package_fontconfig_2_11_1 owned by iuc 
> with revision 2ce32675340e.
> Error installing tool dependency freetype version 2.5.2: Unable to locate 
> required tool shed repository named package_freetype_2_5_2 owned by iuc with 
> revision 3b09e7916896.

In the main overview of the repository I also see the message "Dependency was 
not resolved by any resolver module."  (see package_cairo_resolver.jpg). Is 
this related and something I should worry about? I did not touch the resolver 
configuration, I left the line in galaxy.ini commented.
I also don't understand why it tries to install a different revision of a 
package repo that's already installed. I'm having similar errors for some other 
packages.


Furthermore, when I try to "Get Updates" for cuffdiff, I get an internal server 
error (see cuffdiff_update_error.txt). The same for macs2 (see 
macs2_update_error.jpg).

When I try to install the newest version of cuffdiff from the toolshed, after I 
click "Install to Galaxy", I get a "Request-URI Too Large" error (from apache I 
guess). The last message before it fails in the Galaxy log is "Building 
repository dependency relationships...".


I'm a bit reluctant to update any package repositories I have installed, since 
in the past this lead to dependencies breaking. Also uninstalling and 
reinstalling usually doesn't help, since the database keeps the records and 
once it's messed up it stays messed up. I checked on the galaxy-stable docker 
image and there everything works fine, so I guess it's related to my Galaxy 
instance, not the package/tool repositories.

Any help on how to solve this is greatly appreciated!

Best regards,
Sarah


----
Sarah Diehl
HPC System Administrator

UNIVERSITÉ DU LUXEMBOURG

LUXEMBOURG CENTRE FOR SYSTEMS BIOMEDICINE
Campus Belval | Biotech II
6, avenue du Swing
L-4371 Belvaux
T +352 46 66 44 5360
sarah.di...@uni.lu<mailto:sarah.di...@uni.lu>     
http://lcsb.uni.lu<http://lcsb.uni.lu/>
-----
This message is confidential and may contain privileged information. It is 
intended for the named recipient only. If you receive it in error please notify 
me and permanently delete the original message and any copies.
-----

___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to