I have hit a brick wall when trying to convert wig files from the GEO to bigwig files. Each time I try (and I have tried many times since October), I get the same error. For example, here is a downloaded wig file, that I assigned to the mouse mm8 genome, and the error I got when I tried to convert it to a bigwig file. The dataset came from Bing Ren's lab, and its GEO record is here: http://www.ncbi.nlm.nih.gov/geo/query/acc.cgi?acc=GSM560344

The wig file was uploaded to Galaxy Dec. 8, 2011, and I assigned mm8 rather than mm9 based on the GEO record:

49: GSM560344_03112009_313D2AAXX_B7.wi
~960,000 lines
format: wig, database: mm8
Info: uploaded wig file
display at UCSC main

The details for this upload are as follows:

Tool: Upload File
Name:   GSM560344_03112009_313D2AAXX_B7.wi
Created:        Dec 08, 2011
Filesize:       12.1 Mb
Dbkey:  mm8
Format: wig
Tool Version:   
Tool Standard Output:   stdout
Tool Standard Error:    stderr

Input Parameter Value
File Format     auto
Conditional (files_metadata)    32
Inheritance Chain


The wig-to-bigWig conversion on data 49 (using the wig to bigwig conversion tool in the convert formats toolbox) was run on March 21, 2012 and gave the following error:
 77: Wig-to-bigWig on data 49
0 bytes
An error occurred running this job:line 152351 of stdin: chromosome chr13 has 120614378 bases, but item ends at 120614600 line 298005 of stdin: chromosome chr17 has 95177420 bases, but item ends at 95177625 line 325066 of stdin: chromosome chr16 has 98252459 bases, but item ends at 9825252

The details for this operation are as follows:

Tool: Wig-to-bigWig
Name:   Wig-to-bigWig on data 49
Created:        Mar 21, 2012
Filesize:       0 bytes
Dbkey:  mm8
Format: bigwig
Tool Version:   
Tool Standard Output:   stdout
Tool Standard Error:    stderr

Input Parameter Value
Convert 49: GSM560344_03112009_313D2AAXX_B7.wi
Conditional (settings)  1
Items to bundle in r-tree       256
Data points bundled at lowest level     1024
Clip chromosome positions       True
Do not use compression  True
Inheritance Chain

Wig-to-bigWig on data 49

I gather that the chromosome ends are not being snipped off, even though I toggle this option on the galaxy conversion tool. And I know it's doing something, because if I toggle that option off, I get an error that includes "broken pipe" and simply aborts. I apologize for knowing so little about the bioinformatics involved here. And I'm sure I've overlooked something that is likely obvious to others and/or failed to provide some critical bit of info in this email. But any help would be greatly appreciated.


The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:


To manage your subscriptions to this and other Galaxy lists,
please use the interface at:


Reply via email to