Hi Pasquale,

From a quick look (and I am not the tool-building expert of our team!), I suspect that the problem is with the "format" assigned to the output of the first tool, and input of the second tool. Specifically, "format=string" is problematic, unless you have also defined this in your local install. Even then, having it contain a path to a file deviates from the regular usage (if I have understood your snippet of code correctly).


Our wiki for tool configuration is located here. The wiki has examples, but you can also look at tools in the source code or Tool shed repos to see how "format" is used.
https://wiki.galaxyproject.org/Admin/Tools/ToolConfigSyntax

I don't want to send you away from this list, since I know that you already emailed earlier, but the galaxy-...@bx.psu.edu mailing list is where most tool development questions are discussed. That said, when troubleshooting, individual scripts are not often corrected by the community if the answer is already in the wiki, existing code base, or in a prior discussion. So, making use of these resources is the first place to start. There is a search tool for development topics that can be of great use to locate the bits for you that can be helpful:
http://galaxyproject.org/search/

Try a search with "Admin & Development" - I found in the first few hits this link, which includes the tool config link above plus many other related resources listed at the bottom:
https://wiki.galaxyproject.org/Admin/Tools/Add%20Tool%20Tutorial

Hopefully this helps a little, and others reading the post are welcome to add in more of course!

Jen
Galaxy team

On 1/13/14 7:31 AM, Pasquale Notarangelo wrote:
Hi all,
we are two new galaxy users.

We have developed 2 new tools and we would connect them into a new workflow.

We are able to import both tools and to link them into a workflow but we aren't able to pass the output of the first tool as the input of the second tool.


The first tool calls a bash script that produces a simple string (this is the path of the file generated by the script).

This is the xnl file of the first tool:

<tool id="infnTools_ConcatenateArgumentsTool" name="Concatenate Arguments and generate file Tool">

<description>Concatenate arguments strings and generate file</description>

<command interpreter="bash">concatenateArgumentsAndPutFile.sh $inputArguments</command>

  <inputs>
<param name="inputArguments" type="text" label="ARGUMENTS" optional="false"/>
  </inputs>

  <outputs>
    <data format="string" name="output" />
  </outputs>

</tool>


This is the bash script of the first tool (concatenateArgumentsAndPutFile.sh):

#!/bin/bash
echo "ARGUMENTS:" $@
export PathFile=/tmp/$RANDOM$RANDOM
echo $@ > $PathFile
echo "PathFile:" $PathFile


The xml of the second tool is the following:

<tool id="infnTools_InsertBiomasTools" name="InsertJobs and check the status of Biomas">
  <description>InsertJobs Biomas Tool and check the status</description>

<command interpreter="bash">insertAndCheckBiomasJobs.sh $input </command>

  <inputs>
<param format="string" name="input" type="data" label="Insert path file"/>
  </inputs>

  <outputs>
    <data format="tabular" name="output"/>
  </outputs>

</tool>


When we run the workflow the output of the first tool isn't seen as input of the second tool.

Into the galaxy history we see this value for the input of the second tool: /home/pasquale/galaxy-dist/database/files/000/dataset_83.dat

Also this file is emtpy.


How we can resolve the problem?

Thanks and best regard
Pasquale & Alfonso


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Dott. Pasquale Notarangelo
INFN Istituto Nazionale di Fisica Nucleare - Sezione Bari

Via Orabona, 4 - 70126 Bari, Italy

Tel. ufficio: +39 080-5443194
Interno ufficio: 3194
Mail: pasquale.notarang...@ba.infn.it
Skype: pasquale.notarangelo_1985
Msn: pasqualenotarang...@hotmail.it
Gmail: notarangelo....@gmail.com

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

 http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

 http://galaxyproject.org/search/mailinglists/

--
Jennifer Hillman-Jackson
http://galaxyproject.org

___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

 http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

 http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

 http://galaxyproject.org/search/mailinglists/

Reply via email to