Hi Thomas,

Ok, but still all I hear is I need the latest, latest, latest, and as I stated 
every time I up grade my computer it goes to heck!  So I plan to use my 
computer the way that it is until it dies and I need to somehow buy a new 
computer and a screen reader that will run on it.

BFN

----- Original Message -----
Hi Jim,
Yes, that was definitely one of the reasons I went to straight C++. I
didn't feel people needed to download and install a number of extra
dependencies like the .Net Framework, Managed DirectX, etc. I still
hold to that reasoning
However, you still need to have the latest C++ Windows libraries to
run my games because I am using a newer version of Visual C++ that
links against the Windows 7.1 Windows Platform SDK libraries which are
newer than those that ship with XP by default. However, downloading
the latest Visual C++ runtime update is much much smaller than the
.Net Framework and Managed DirectX. It is just one of those prices you
pay for trying to maintain an upto date C++ application for Windows
while maintaining some backwards compatibility with older Windows
releases like XP that are beginning to show their age from a
programming point of view.
The other reason I picked C++ is eventually, I don't know when, I'd
still like to make non-Windows releases of my games for Mac OS X and
Linux. It is not really feasable to do that using .Net because the
Mono Framework for Linux and Mac isn't completely 100% compatible with
the Microsoft .Net Framework. Instead a game written in C++ is mostly
compatible with non-Windows releases already, but I would certainly
have to rewrite audio, input, and other operating system specific
parts of the core to support non-Windows operating systems. Having it
in C++ atleast makes that possible, but still would be something of a
major update to the code as well.
So to answer your question I'm not asking anyone to be running the
latest and greatest Windows releases to play my games. I happen to
have an older laptop here, I got back in 2005,  with Windows XP SP3 on
it and Mysteries of the Ancients runs fine on it provided I have
installed the latest XP Windows updates and have installed the latest
Windows C++ libraries. So I don't see asking a user to apply a few
Windows updates, which a person should do anyway for the latest
critical updates, security patches, and various ccompatibility updates
as a big issue. Usually installing the dependencies you would need for
my games are less than 50 MB not 300 or more MB.
As to why I am using the latest C++ libraries the answer is two-fold.
Number one, I happen to be running Windows 7 on my newer laptop and
since I want it to work smoothly with Windows 7 that means I should be
linking against the most compatible libraries for that operating
system. Number two, I'm using the latest Visual Studio development
tools and by default they link against the newest Windows Platform SDK
headers and libraries. It doesn't make much sense to go to the
Microsoft website and download a much older release of the Platform
SDK to use the lowest common denominator when newer C++ libraries are
available for XP anyway. The customer just needs to install them to
bring his/her XP system up to date is all.
So I have not changed my mind. The issue is a technical one not a
personal one. I don't see the need to post a dozen versions of the
program on the website like for Windows XP click here, for Vista click
here, and for Windows 7 click here, etc. That's just stupid when I can
design the program to run on any and all of the above provided  the
persons computer has reasonably new version of the XP, Vista, or
Windows 7 C++ libraries.


HTH


On 7/8/10, Jim Kitchen <j...@kitchensinc.net> wrote:
Hi Thomas,

Just wondering.  I thought that you had decided to program in straight C++
so that people did not need to down load 300 meg of up grades to be able to
run your game like they did when it was in C net.  But now you have changed
your mind and again people need to be running the latest greatest software
from Microsoft right?

Maybe if I could afford a new computer and a screen reader that would run on
it I might check out your game.  But as it is now, every time that I try to
up grade my computer it runs much worse.  The last time I did this was so
that I could listen to a radio stream from WMMS Rover's Morning Glory, now
every time that I close Internet Explorer it blows up my desk top etc.  So I
need to reboot.  Even a sighted person with a mouse can not use my computer
without a reboot.

http://roverradio.com

But I guess my point is, are you not going backwards to forcing people to up
grade like when the game was in a net language?

Just asking.

BFN

     Jim


    Jim

I have found that nothing written in fine print is ever good news.

j...@kitchensinc.net
http://www.kitchensinc.net
(440) 286-6920
Chardon Ohio USA
---
Gamers mailing list __ Gamers@audyssey.org
If you want to leave the list, send E-mail to gamers-unsubscr...@audyssey.org.
You can make changes or update your subscription via the web, at
http://audyssey.org/mailman/listinfo/gamers_audyssey.org.
All messages are archived and can be searched and read at
http://www.mail-archive.com/gam...@audyssey.org.
If you have any questions or concerns regarding the management of the list,
please send E-mail to gamers-ow...@audyssey.org.

Reply via email to