David Daney <david.da...@cavium.com> writes:

> On 03/06/2012 05:14 AM, Rainer Orth wrote:
>> "Joseph S. Myers"<jos...@codesourcery.com>  writes:
>>>>    There's one particular issue: the change to java/io/File.java required
>>>>    my to regenerate the .class file in classpath.  I've used Sun javac
>>>>    -target 1.5 for that and hope I got it right.
>>> I'd have expected regeneration to use GCJ built to use ECJ, though I don't
>>> know.
>> I've never tried this.  Given that the .class file lives below
>> libjava/classpath and has to be synced with upstream Classpath anyway, I
>> hope the Java maintainers will take care of that.
> This it documented (although perhaps badly) in install/configure.html
> You should use --enable-java-maintainer-mode, this will cause the build to
> use ecj and gjavah to regenerate all the generated files in the 'standard'
> manner.

I tried that route, but failed: even with ecj1 and gjavah scripts in
PATH, I get

-B/usr/local/i386-pc-solaris2.11/bin/ -B/usr/local/i386-pc-solaris2.11/lib/ 
-isystem /usr/local/i386-pc-solaris2.11/include -isystem 
/usr/local/i386-pc-solaris2.11/sys-include  -m64 -C -g  -fsource=1.5 
-ftarget=1.5 --bootclasspath='' 
 -d /vol/gcc/src/hg/trunk/solaris/libjava/classpath/lib @classes
no classpath specified
make[6]: *** [compile-classes] Error 1

I gave up and checked in the File.class file produced with Sun javac.


Rainer Orth, Center for Biotechnology, Bielefeld University

Reply via email to