> Basically. Except it's:
> Fred fred = (Fred)doSomething();  in some cases.

Hmmm.... it seems like that local variable is unnecessary if it's not
being used later on.... if this is a JUnit test and it's meant to ensure
a certain type is return, seems like this:

assertTrue("Whoa, doSomething returned a non-Fred type!", doSomething()
instanceof Fred);

That way you'll get a nice error message rather than just a
ClassCastException if the test fails.

> When I raised the discussion a while back on removing these 
> [based on your
> error reporting] there was a view that the above improves the testing,
> even if it is not usually considered good style.
> So I'm looking for a configuration change in the Jakarta 
> Commons/Sandbox
> [at least] reporting which removes these and makes it easier 
> to focus on
> the real problems.

Does the above assertTrue() thing work for you?  Or maybe I'm not
understanding the problem completely...



To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to