>>>> I've got a fresh Gentoo installation that does not boot. I just end up in
>>>> the Grub2 shell.
>>>> However when there if I do 'set root=(md/0)' and 'configfile 
>>>> /grub/grub.cfg'
>>>> I do get to the Grub2 menu where Gentoo boots just fine.
>>>> /boot and / are both on mdadm devices.
>>>> I've tried re-running grub-mkconfig and grub-install several times without
>>>> luck.
>>>> I've added domdadm to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub.
>>>> Drives sda/sdb use GPT disklabels and have 20M BIOS boot partitions first.
>>> To which device are you installing grub?
>>> Check what "core.img" prefix and modules grub-install is using with
>>> grub-install --debug $your_device 2>&1 | grep grub-mkimage
>>> [I hit a similar problem with mdadm 6 or 7 years ago and had to create
>>> a custom "core.img" to boot normally. You might have to do the same
>>> but i would've thought that this problem's been solved. I haven't
>>> encountered it since.]
>> I install grub to devices sda and sdb in the hope I can boot from both/either
>> m / # grub-install --debug /dev/sda 2>&1 | grep grub-mkimage
>> grub-install: info: grub-mkimage --directory '/usr/lib/grub/i386-pc'
>> --prefix '(mduuid/46488b259685a3b9c52b7449d592dc80)/grub' --output
>> '/boot/grub/i386-pc/core.img' --format 'i386-pc' --compression 'auto'
>> 'ext2' 'part_gpt' 'part_gpt' 'diskfilter' 'mdraid1x' 'biosdisk'
>> m / #
> [ I assume that "46488b259685a3b9c52b7449d592dc80" is the UUID that's
> displayed as "UUID" or "Array UUID" when you use "mdadm -D ..." or
> "mdadm -E ..." respectively ]

Almost, mdadm says 46488b25:9685a3b9:c52b7449:d592dc80

> Does "set" in the grub shell display
> "prefix=(mduuid/46488b259685a3b9c52b7449d592dc80)/grub" and
> "root=(mduuid/46488b259685a3b9c52b7449d592dc80)"?

Yes, I messed up the prefix=-line when retyping it.

> Does "grub-probe -t drive -d /dev/md0" output "(mduuid/...)" or
> "(md/0)" or "(md0)"?

It ouputs "(mduuid/46488b259685a3b9c52b7449d592dc80)"

Reply via email to