On Wed, Feb 14 2018, Arve Barsnes wrote:

> On 14 February 2018 at 17:44, allan gottlieb <gottl...@nyu.edu> wrote:
>> I have never needed package.provided before so am probably doing it
>> wrong.
>>
>> Any help would be appreciated.
>
> The way I understand it, /etc/portage/ doesn't support that, it should
> go in /etc/portage/profile/
>
> Cheers,
> Arve

You are correct thanks.

However now
  emerge --update ... @world
gives a red-letter warning that dependent packages are in package.provided,
which is true.  It then gives three possible remedies.

Rather than facing that msg every emerge and possibly learning too well
to ignore warnings, I adopted the third remedy and removed the
package.provided files.

I will temporarily use a two step emerge --update ... @world

1.  emerge --update --pretend ... @world
2.  emerge -1 ... files suggested by 1 minus the bad chromium and webkit-gtk

thanks again.
allan

Reply via email to