Hi list

I have a bit of a weird issue.  I recently acquired a used server (Fujitsu 
Primergy TX140 S1) via a friend of mine.  I have Gentoo installed on it now 
and overall it works fine save for one perplexing issue [0]: The bootloader 
hangs when booting without a keyboard attached.  I tried it with both GRUB and 
systemd-boot (which works nicely in combination with kernel-install); both 
only work with a keyboard attached.  GRUB hangs when the countdown starts, 
while systemd-boot hangs when the cursor first appears, but before the boot 
entries are listed.  In both cases the cursor freezes.

I'm curious if anybody has seen this issue before and/or has any idea how to 
solve it.  The only resources I could find online that seem related are [1] 
(different OS, no resolution, hints at BIOS), [2] (which provides a potential 
solution, though I'm not sure whether I can actually implement it), and [3] 
(the patch didn't help).  There was also a related systemd bug at [4].

I updated the BIOS, but that helped as much as anticipated, that is, not at 
all (it was at the penultimate version already).  I also tried unplugging the 
display in case the BIOS was expecting a keyboard then.

Any help is much appreciated.

[0] Well, there's a second one, too, but I'll have to see if it shows up 
[3] https://bugs.archlinux.org/task/44923
[4] https://github.com/systemd/systemd/pull/3735

Marc Joliet
"People who think they know everything really annoy those of us who know we
don't" - Bjarne Stroustrup

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply via email to