fixeria has posted comments on this change. ( 
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370 )

Change subject: pcu: Refactor GPRS infrastructure to keep state and simplify 
tests
......................................................................


Patch Set 5:

(16 comments)

https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn
File pcu/GPRS_Components.ttcn:

https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@78
PS5, Line 78: uint8_t
boolean? Ideally, we should use something like "bitstring length (8..11)" or a 
union of BIT8 abd BIT11 here.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@79
PS5, Line 79: PCUIF_BurstType
Not sure if access burst type should be stored here, as you don't really need 
to match it in the assignment message.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@160
PS5, Line 160: dynamic
It also makes sense to parse both 'usf' and 'usf_granularity' here. Can be done 
later though.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@169
PS5, Line 169: dynamic
It also makes sense to parse both 'usf' and 'usf_granularity' here. Can be done 
later though.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@204
PS5, Line 204: dl_ass
This template is not used in this function...


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@249
PS5, Line 249: ms.burst_type := BURST_TYPE_0;
This should be kept as a parameter of the function that actually sends RACH.ind 
to the IUT.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@294
PS5, Line 294: tr_RLCMAC_DL_PACKET_ASS
So by default, this function would match DL Assignment, while it can also 
handle UL Assignment. Maybe using '?' by default would make more sense?


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@294
PS5, Line 294: imm_ass_rlcmac
This name is confusing as there is no RLC/MAC version of the RR Immediate 
Assignment.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@299
PS5, Line 299: f_rx_rlcmac_dl_block
Please add a TODO/FIXME here stating that we need an alt statement here.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@310
PS5, Line 310: Wrong TLLI
This probably means that received assignment is not for us, and we should wait 
for another one? At least a comment is needed here.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@327
PS5, Line 327: uint16_t
Why 16 bits? Should be 8 I believe.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@334
PS5, Line 334: 871
TODO (separate change idea): use mp_trx0_arfcn here.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@353
PS5, Line 353: establish
This name is confusing. Without looking at the code, I would think that it 
somehow establishes a Downlink TBF, but actually we *expect* DL TBF assignment 
here.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@362
PS5, Line 362: uint32_t fn := 0
template uint32_t fn := ?


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@381
PS5, Line 381: data := f_pad_oct(data, 23, '00'O); /* CS-1 */
There must be a comment that padding only works for CS-1. A payload of more 
than 23 octets would be sent unaligned.


https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370/5/pcu/GPRS_Components.ttcn@405
PS5, Line 405: f_ms_tx_ul_data_block_multi
Maybe call it f_ms_tx_rand_ul_data_blocks()? The point is that the function 
generates payload itself, so it should be reflected in its name.



--
To view, visit https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/18370
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.osmocom.org/settings

Gerrit-Project: osmo-ttcn3-hacks
Gerrit-Branch: master
Gerrit-Change-Id: Ib3fee37580f0ea0530a659dec83656799bf57288
Gerrit-Change-Number: 18370
Gerrit-PatchSet: 5
Gerrit-Owner: pespin <pes...@sysmocom.de>
Gerrit-Reviewer: Jenkins Builder
Gerrit-Reviewer: fixeria <axilira...@gmail.com>
Gerrit-Reviewer: laforge <lafo...@osmocom.org>
Gerrit-Reviewer: pespin <pes...@sysmocom.de>
Gerrit-Comment-Date: Thu, 21 May 2020 18:21:40 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment

Reply via email to