I don't understand why anyone would choose to use VLC to record the
BBC streams. VLC is clunky, difficult to get working and arcane. Its
interface is really awful.

Simply download Audacity (which is free), and use its record button
when your stream starts. The only trickiness is at the end when you
don't save the audio output, instead you export it to a file of your
choice. Audacity exports my files as WAV, but you can as easily get it
to use FLAC if you prefer.

And I assume you know that you don't have to record the concert live,
as all R3 Proms 2017 output is available in lossless format in iPlayer
for 30 days.

Paul Thornett

On 6 August 2017 at 02:30, RS <richard...@zoho.com> wrote:
> A few days ago Vangelis kindly told us how to record the BBC R3 FLAC streams
> using a recent nightly build of VLC.  Has anyone been able to play the
> recordings other than through a software player such as VLC?
> I can play a recording with the nightly build of VLC.  The speakers on my PC
> are adequate, but not suitable for listening to music, so it defeats the
> object if I can't play the recordings on anything else.
> If I try to play it with VLC v2.2.6 (Umbrella) there is silence.  The
> Statistics tab shows the same number of lost buffers as decoded blocks and 0
> played buffers.  The SanDisk Clip Jam claims to be able to play FLAC,
> although there is a warning on the web site that the v1.12 firmware is
> needed.  It plays the Hallelujah.flac test file from The Sixteen (and it
> used to play it with the v1.10 firmware) but it will not play the BBC FLAC
> recording.  It displays, "Unsupported file format".
> It is in an OGG container.  I tried using ffmpeg v3.2.4 with -acodec=copy to
> remultiplex it to a FLAC container.  I got an error message
> Could not write header for output file #0 (incorrect codec parameters ?):
> Invalid data found when processing input
> I then tried converting the FLAC in an OGG container to FLAC in a FLAC
> container.  I got a huge number of error messages of the form
> [flac@04fdc8a0] Application provided invalid, non monotonically increasing
> dts to muxer in stream 0:  122872320 >= 122867712
> I thought something had gone wrong so I stopped it.  I then noticed the
> output file size was not zero, but about 5MByte.  I discovered I could play
> it and it was about 42s long.  I then let the conversion run to completion.
> I got a final error message
> Error while decoding stream #0:0: Invalid argument
> followed by the usual size, time, bit rate and speed indications.
> I found the output file was complete and I could play it in VLC v2.2.6 and
> the SanDisk Clip Jam.
> The command I used for the conversion was
> ffmpeg -i=<infile>.ogg -f=flac -sample_fmt=s16 <outfile>.flac
> _______________________________________________
> get_iplayer mailing list
> get_iplayer@lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/get_iplayer

get_iplayer mailing list

Reply via email to