On Mon, 31 Mar 2003 19:58:29 +0200
Sven Neumann <[EMAIL PROTECTED]> wrote:
> Ernst Lippe <[EMAIL PROTECTED]> writes:
> > As promised here is my API proposal for a plug-in preview widget.
> > You can find it at http://refocus.sourceforge.net/preview.
> > Please examine it critically, this should be a preview that
> > should be usable for a very wide range of plug-ins.
> > Because I would like to reuse this proposal (or what is left of it
> > after the discussion) for the final documentation I
> > also welcome minor comments such as spelling mistakes, grammar
> > corrections, coding errors and such.
> one thing that I noted at first glance is the namespace. It is
> absolutely unacceptable to have any types or function names in the
> GIMP API that don't have a GIMP prefix. I'd even prefer to have
> everything that is related to this widget be under the same
> namespace. Unfortunately GimpPreview is already taken, so we either
> need to change the name of the core object or find a new one for the
> plug-in preview.
I fully agree that the names must be changed.
The problem is how? Maurits suggested GimpEffectPreview, which
is not a bad name, but I don't really like having to preview every
function with gimp_effect_preview_ . I know it is a bit old-fashioned
but I still think that source code should be readable on a tty
with 80 characters.
P.S. Of course the most logical solution is to change the name of
the core widget. My widget is derived from Shawn Amundson's GimpPreview
widget that was written in 1998, and that was long before some
GIMP developer tried to claim that name. It is clear that
this is an obvious infringement of our trademark.
Gimp-developer mailing list