On 16 Jun 2004, Sven Neumann wrote:

> Hi,
>
> kovzol <[EMAIL PROTECTED]> writes:
>
> > I had many hours of headache figuring the right solution out to write my
> > own code in Gimp-Perl --- I was browsing the internet a lot, but there
> > were many versions of the same statements in Gimp-Perl with different
> > syntax. :-( So I'm also afraid that my script will be incompatible with
> > 2.0.x --- that's why I don't really want to upgrade yet. :-)
>
> Most likely your script will just work. Fear of incompatibility is not
> really a good reason to stick to an outdated and unmaintained version.

Dear Sven,

as a developer of other software, I can agree with you. In addition,
relying on your information, I installed gimp-2.0.2 and Gimp-2.0
(AKA Gimp-Perl :-). (I'm not a Perl expert, it was a craze to install new
and new Perl modules... ;-)

Now Gimp starts OK, and I can work with it.

If I want to test the files in Gimp-2.0/t, I get the following:

[EMAIL PROTECTED]:/usr/src/packages/SOURCES/Gimp-2.0/t> ls
loadlib.t  load.t  run.t
[EMAIL PROTECTED]:/usr/src/packages/SOURCES/Gimp-2.0/t> perl run.t
1..26
ok 1
ok 2 # skip
ok 3 # skip
ok 4 # skip
ok 5
ok 6
ok 7
ok 8
run.t: unable to read the Perl-Server at run.t line 109. (ERROR)
run.t: required callback 'net' not found (ERROR)
[EMAIL PROTECTED]:/usr/src/packages/SOURCES/Gimp-2.0/t> perl loadlib.t
1..1
ok 1

Now as I start gimp-2.0.2 and start a Perl server using the graphical user
interface:

[EMAIL PROTECTED]:/usr/src/packages/SOURCES/Gimp-2.0/t> gimp-2.0 &
[1] 17697
[EMAIL PROTECTED]:/usr/src/packages/SOURCES/Gimp-2.0/t> 1087410137: server
version 2 started
1087410137: accepting connections on
/tmp/gimp-perl-serv-uid-500/gimp-perl-serv

[EMAIL PROTECTED]:/usr/src/packages/SOURCES/Gimp-2.0/t> perl run.t
1..26
ok 1
ok 2 # skip
ok 3 # skip
ok 4 # skip
ok 5
ok 6
ok 7
ok 8
run.t: unable to read the Perl-Server at run.t line 109. (ERROR)
run.t: required callback 'net' not found (ERROR)

Is this OK? (I got the same output when no Perl-server was started.)

Now I'm trying to start my gimp-1.2 Perl-Fu script (attached):

[EMAIL PROTECTED]:~> cd /home/wmi/cvs/wmi/ui/
[EMAIL PROTECTED]:/home/wmi/cvs/wmi/ui> ./oval-buttons.pl
1087410392: accepted unix connection
Illegal default font description for perl_fu_mysite_buttons: -*-luxi
sans-medium-r-*-*-24-*-*-*-*-*-iso8859-2
oval-buttons.pl: Expected an INT32 but got 'BG_IMAGE_FILL'. Add '*1' if
you really intend to pass in a string at ./oval-buttons.pl line 110 (DIE)
1087410424: closing connection 9 (45 requests in 32 seconds)

The error message appeared after I changed the font (successfully) and
pressed "OK" (finally, to generate the .xcf file).

In gimp-1.2 there were no such problems (and the .xcf file was
successfully generated).

Could you please help?

TIA, Zoltan

Attachment: oval-buttons.pl
Description: Perl program

_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to