On Wednesday 11 January 2006 09:28, Owen Cook wrote:
> --
> On Wed, 11 Jan 2006, Brannon King wrote:
> > I'm sorry if this is a stupid question. Traditionally I'm a Windows
> > programmer though I dual boot Fedora for some rare uses. (I'm open to
> > other distro options!) I tried to compile GIMP 2.3.6 on FC4 the other
> > day. That didn't work: I needed the 2.8 GLIB stuff. I downloaded the
> > source code, etc., for it and compiled GLIB. That worked, but it
> > installed it into usr/local and the GIMP compile still fails. How do I
> > make the GIMP compile read the libraries from the correct location? And
> > I'm not real sure the GLIB compile used the right libraries. Any good
> > references on the matter would be appreciated.
> You would have needed the latest glib,atk,pango and gtk
> They should have been available from Red Hat?
> If they weren't you should have built them like
> ./configure --prefix-/usr

First of all it's:

./configure --prefix=/usr

Secondly, this is considered a bad idea. That way, you'll override the files 
of your RPMs, and mess up your system. Once the RPM is upgraded, you'll lose 
your files. A better solution would be to either install it under /usr/local 
and point the GIMP to it, or better yet install it under a unique path 
(like /usr/local/apps/glib-2.8) and also point the GIMP there. That way, you 
can remove such installed programs easily once you don't need them.


        Shlomi Fish

Shlomi Fish      [EMAIL PROTECTED]
Homepage:        http://www.shlomifish.org/

95% of the programmers consider 95% of the code they did not write, in the
bottom 5%.
Gimp-developer mailing list

Reply via email to