Hi,

    I have a script-fu that worked fine in 2.4 and it's broken in 2.6.
It had a conditional to apply the layer's mask if it exists. This is
what it read:

  (cond
      ((gimp-layer-get-mask SharpenLayer)(gimp-layer-remove-mask SharpenLayer 
0))
  )

Now it is broken.

    How do I tell script-fu 2.6 to apply a layer mask (if it exists)?
I was unable to find something like a boolean gimp-layear-has-mask,
and gimp-layer-remove-mask returns an error if the mask does not exist.

    Thanks!!

        L.

_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to