Another update-

I restarted my compuyer and tried again.  This time it took 5 times
inthe console to come back:

> (gimp-parasite-attach (list "test-counter" 1 "123"))
(#t)
> (gimp-parasite-list)
(2 ("exif-orientation-rotate" "test-counter"))
> (gimp-parasite-find "test-counter")
(("test-counter" 1 ""))
> (gimp-parasite-attach (list "test-counter" 1 "123"))
(#t)
> (gimp-parasite-find "test-counter")
(("test-counter" 1 ""))
> (gimp-parasite-attach (list "test-counter" 1 "123"))
(#t)
> (gimp-parasite-find "test-counter")
(("test-counter" 1 ""))
> (gimp-parasite-attach (list "test-counter" 1 "123"))
(#t)
> (gimp-parasite-find "test-counter")
(("test-counter" 1 ""))
> (gimp-parasite-attach (list "test-counter" 1 "123"))
(#t)
> (gimp-parasite-find "test-counter")
(("test-counter" 1 ""))
> (gimp-parasite-attach (list "test-counter" 1 "123"))
(#t)
> (gimp-parasite-find "test-counter")
(("test-counter" 1 "123"))

It seems completely inconsistent.  The parasite always gets created
but more often than not has a "" value.

-Rob A>

On Thu, Jan 29, 2009 at 6:58 PM, Rob Antonishen
<rob.antonis...@gmail.com> wrote:
> Thanks for the check.  I am using Windows XP, Gimp 2.6.0
>
> Any other suggestion?
>
> -Rob A>
>
> On Thu, Jan 29, 2009 at 6:46 PM,
> <saulgo...@flashingtwelve.brickfilms.com> wrote:
>>
>> Quoting Rob Antonishen <rob.antonis...@gmail.com>:
>>
>>> OK -
>>>
>>> This could be a problem with tinyscheme and parasites.
>>>
>>> Here is a a console trace:
>>>
>>>> (gimp-parasite-list)
>>> (1 ("exif-orientation-rotate"))
>>>> (gimp-parasite-attach (list "test-counter" 1 "123"))
>>> (#t)
>>>> (gimp-parasite-list)
>>> (2 ("exif-orientation-rotate" "test-counter"))
>>>> (gimp-parasite-find "test-counter")
>>> (("test-counter" 1 ""))
>>>> (gimp-parasite-attach (list "test-counter" 1 "123"))
>>> (#t)
>>>> (gimp-parasite-find "test-counter")
>>> (("test-counter" 1 "123"))
>>>
>>>
>>> The attach didn't work the first time, but did the second time.
>>
>> When I performed the above steps in the console, I did not encounter
>> the anomaly you relate above. I have used parasites in various scripts
>> without ever encountering such strange behavior.
>>
>> _______________________________________________
>> Gimp-developer mailing list
>> Gimp-developer@lists.XCF.Berkeley.EDU
>> https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer
>>
>
_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to