On 11/09/2010 07:17 AM, Martin Nordholts wrote:
> On 11/08/2010 11:22 PM, Ofnuts wrote:
>> I'm trying to have coexisting a locally built 2.7 and a packaged 2.6.8.
>>
>> 2.6.8 goes to /usr/bin and /usr/lib and 2.7 installs into /usr/local/lib
>> and /usr/local/bin
>>
>> I start 2.7 via a shell that export LD_IBRARY_PATH and updates the PATH
>> so tha the /usr/local stuff goes first.
> Just a couple of tips:
>    * Don't install into a prefix in a prefix, rather use /usr and /opt

Ain't me... I used all defaults in the Git build scripts.

>    * You shouldn't need to set LD_IBRARY_PATH when you run (only when you
>      ./configure) because built binaries will have library paths
>      hardcoded in them through rpath [1], unless you disabled that.

OK, will look that up.

Thanks.
_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to