On Fri, 10 Nov 2000, David Monniaux <[EMAIL PROTECTED]> wrote:
> I compiled Gimp under Solaris with --with-included-gettext. Trying to run
> it with LANG=fr... does not yield anything translated. Nevertheless, Gimp
> seems to load the translation file (seen in strace).
> Has anyone else noticed this behavior, or is it my setup?

I compiled Gimp 1.1.29 under Solaris 2.6 without the included gettext
(I have GNU gettext 0.10.35 installed in my path, and "configure" is
happy with it).  I had never tried to set LANG=fr under Solaris, so I
just tried to see if I had any problems.  Well, I got the answer in
less than 2 seconds...

csh> setenv LANG fr
csh> gimp
gimp: fatal error: Segmentation Fault
gimp (pid:15480): [E]xit, [H]alt, show [S]tack trace or [P]roceed: s
#0  0xef560cb8 in g_on_error_stack_trace (prg_name=0xeffffc24 "gimp")
#1  0xef560ba8 in g_on_error_query (prg_name=0xeffffc24 "gimp") at gerror.c:133
#2  0x801d4 in gimp_fatal_error (fmt=0xef30e916 "Segmentation Fault")
#3  0xdf2a4 in gimp_sigfatal_handler (sig_num=11) at main.c:464
#4  <signal handler called>
#5  0xef29c2c4 in key_2_text ()
#6  0xef29c188 in dcgettext_u ()
#7  0xef29ba0c in gettext ()
#8  0x343f8 in make_initialization_status_window () at app_procs.c:373
#9  0x34970 in app_init () at app_procs.c:502
#10 0x33c40 in gimp_init (gimp_argc=0, gimp_argv=0xeffffb20) at app_procs.c:138
#11 0xdf238 in init () at main.c:430
#12 0x140228 in user_install_verify (user_install_callback=0xdf220 <init>)
#13 0xdf1fc in main (argc=1, argv=0xeffffb1c) at main.c:396

It crashed before opening any windows.  I tried "truss" to see the list
of system calls that are done before crashing, and I see that it crashes
soon after opening and mmap'ing ".../lib/locale/fr/LC_MESSAGES/gimp.mo".
So it does open the file, but it crashes immediately afterwards.


Reply via email to