On 02/06/2013 01:55 PM, Akkana Peck wrote:
> Steve Kinney writes:
>> The GIMP's tear-off menus do not seem to work on Linux platforms.
> [ ... ]
>> I could not find a "real fix" for this, I did see a practical work
>> around:  Hit the space bar after clicking on the desired command,
>> and viola, the command is executed.
> Thank you! I've really missed the tear-offs -- they haven't worked
> for me since 2.6 came out -- and that will help.

Aha!  Now at least I know it's not my insanity - or ignorance -
making this happen.

> Are you on Ubuntu?  A discussion on #gimp a few weeks ago suggested
> that it was a problem with Ubuntu's GTK patches. And indeed, when I
> tried it on a non-Ubuntu system, tear-offs worked fine. They've
> failed for me on at least three different Ubuntu releases, maybe as
> many as five.  Though it works for Ofnuts on Kubuntu, so it's not
> ALL Ubuntus ...  I haven't had a chance since the discussion to try
> building a vanilla GTK on my Pangolin system to see if that cures
> the problem.

I am using Mint with Cinnamon, which is a fork of Gnome 3 with Gnome
2 style desktop features.  Mint 14 is built on top of Ubuntu
Quantal, so in effect it is a Ubuntu system.  Synaptic says I have
libgtk-3-0 version 3.6.0-0ubuntu3.2 from the Quantal repo on board.

Odd thing is, the tear off menus in Bluefish work normally.

> Anyway, broken tear-offs are super annoying, have been a problem for
> years, and although I still wish for a real fix, your workaround is
> very helpful. Thanks!

I saw the spacebar trick in a response to an old help forum thread
about the broken tear off menus.  It's nice to have tear off menus back.



gimp-user-list mailing list

Reply via email to