Thanks for the attempts to help, but I still don't get it. How does "make uninstall" help me?
does it uninstall previous versions? If not, I don't see how it can help.

I have tried setting PKG_CONFIG_PATH to /usr/local/lib/pkg-config as well as to /usr/lib/pkg-config

The errors I get in the 2 cases when I run configure are different. In one case it tells me my GLIB is too old and it quits. In the second case it says, yes, I see 2.4.8, (the rest of the message is in my earlier email -- see below).

It seems that the pkg-config is getting inconsistent values for the library path.

How do I remove the old version of glib?


On Mar 21, 2005, at 3:44 PM, Jeff Trefftzs wrote:

On Mon, 2005-03-21 at 14:33 -0500, Micheal LeVine wrote:
I have been trying to build GIMP 2.2.0 from source, since the RPM for
my OS (Redhat 9) is way out of date.

The configure command fails:
checking for GLIB - version >= 2.4.5...
*** 'pkg-config --modversion glib-2.0' returned 2.4.8, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable
*** to point to the correct configuration files
configure: error: Test for GLIB failed. See the file 'INSTALL' for help.

I have configured, made and installed GLIB and have corrected LD_LIBRARY_PATH and PKG_CONFIG_PATH. I cannot get past this problem with the version conflicts in GLIB.

Any help will be appreciated

Looks like you're hitting the dependency hell problem. Your old glib came from rpms, your new one from source. Can you track down the appropriate rpms for the later glib and install them instead? I'd suggest first doing a "make uninstall" of the fresh new glib that you just spent all that time building.

The problem is that you have the new glib installed in /usr/local
(probably), but still have the old rpm installed in /usr.


_______________________________________________ Gimp-user mailing list

_______________________________________________ Gimp-user mailing list

Reply via email to