I am new to gimp and have been trying to use gimp to position and size
images on a letter size canvas for printing using the method I have
used with Photoshop Elements. I am running gimp 2.7 in Knoppix/Debian
Linux. (I saw the same behavior gimp 2,6.) I used apt-get to do the

I think that I may be seeing problems with both the resize tool and
layer manipulation.

The steps I go through are:

   1. Create a new image (image A) using the US-Letter template. This
      is the image I will be printing.

   2. Open an image (image B) I wish to add to image A.

   3. Make Image B active, Edit->Copy.

4. Make Image A. Edit->Paste.
   5. Select scale tool and drag a corner to enlarge the image.

   6. Click on the scale button.

I get a partial image the same size as the original one I tried to
resize but it only containing a corner of the enlarged image.  I think
that this is a bug.

I tried this with gimp 2.7 on Windows XP and it seemed to work as I
expected; i. e., the pasted image was enlarged when I clicked the
scale button.  This differing behavior suggests that this is indeed a
bug in the Linux version.

Also, if I open, say, three images and copy-and-paste them onto a
fresh letter-size image, I was expecting to see 4 layers, a background
layer and three floating selection layers as I get when doing this in
Photoshop Elements.  What I see instead is a background layer
containing the first two images I copy-and-paste'ed plus one floating
selection layer.  Is this the correct behavior?  I am surprised by the
'flattening' of the background and the earlier images. It happens with
both the Linux version and the XP version.


Don Rozenberg

Gimp-user mailing list

Reply via email to