David Woodfall wrote:
On (08:03 18/06/07), Sven Neumann <[EMAIL PROTECTED]> put forth the proposition:

On Sun, 2007-06-17 at 18:51 +0100, David Woodfall wrote:

The program 'gimp' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 18775 error_code 191 request_code 158 minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
I can only guess, because you didn't give us much information about your
system. But you are most likely running the broken version of XLib, see

It turned out to be a bad version of Cairo (1.4.8). Upgrading to 1.4.10
seems to have fixed it.

Thanks for the note - I ran into the same problem the other day.
Both versions of gimp were failing. Installing the new version of cairo worked.


Gimp-user mailing list

Reply via email to